ios woa ITMS-90179 Signature de code non valide/ITMS-90209 Alignement de segment non valide




voir mes applications sur itunes (4)

ERREUR ITMS - 90179 Signature de code invalide. L'exécutable 'Payload / UFO.app / UFO' doit être signé avec un certificat contenu dans le profil d'approvisionnement.

ERREUR ITMS - 90209 Alignement de segment non valide. Le binaire de l'application sur 'UFO.app/UFO' n'a pas d'alignement de segment correct. Essayez de reconstruire l'application avec la dernière version de Xcode.

J'ai eu ces deux erreurs, peu importe ce que j'essaie. J'ai effacé tous mes profils et certificats, je les ai refait et même refait l'ID d'application plusieurs fois et rien ne s'est produit et toujours la même erreur. J'ai aussi mis à jour XCode et toujours les mêmes erreurs.

J'ai utilisé une application Wildcard pour créer mon fichier .ipa dans Flash Pro CC en sélectionnant l'Apple App Store et j'ai essayé de le publier via le chargeur d'application.

Y a-t-il une solution à ces deux problèmes? Merci.


J'ai eu ITMS-90179 télécharger une application iPhone faite avec Marmalade SDK. Je l'ai résolu de cette façon:

1.- Supprimé tous mes certificats de distribution sur le portail de développement Apple

2.- Création d'un nouveau certificat de distribution

3.- Supprimé tous mes profils de provisionnement de distribution

4.- Création d'un nouveau profil de provisionnement de distribution

5.- Génération d'un nouveau fichier .ipa en utilisant le .mobileprovision de l'étape 4

6.- Tenté de télécharger celui-ci sur l'App Store, cette fois, cela a fonctionné.

J'espère que cela aide!


mon anglais n'est pas si bon mais je vais essayer de m'expliquer le mieux que je peux ... y juste résoudre cette erreur que j'avais aussi "ERREUR ITMS - 90179 Invalid Code Signing La Charge Executable '/ UFO.app / UFO 'doit être signé avec un certificat contenu dans le profil d'approvisionnement "..... Tout d'abord, mon application utilise des notifications push, j'ai donc créé un certificat de notification push et l'installer sur mon trousseau (aps_production), avec mon application certificat de distribution (ios_production.cer), et j'exportais mon certificat de distribution d'application (ios_production.cer) en utilisant le trousseau de clés pour l'exporter vers le fichier .p12 .... de cette façon je recevais cette erreur ... ce que je faisais est que j'ai effacé tout sur mon trousseau et juste installer le ios_distribution.cer sans le aps_production.cer, de cette façon je corrige ce problème ..... il semble que si vous exportez au .p21 avec d'autres fichiers sur votre trousseau lié à votre même application votre certificat obtient et erreur ... espérons que cela vous aide ...


Il semble y avoir un conflit avec les certificats dev et prod. J'ai finalement pu soumettre en suivant ces étapes:

(1) aller dans le trousseau et supprimer les deux certificats (dev & distribution)

(2) aller au site Apple et télécharger le certificat de distribution seulement

(3) installer le certificat de distribution seulement!

(4) exporter p12 à partir de la clé privée

(5) aller à apple et régénérer / télécharger le profil de provisionnement de distribution.

De là, ça a bien fonctionné, ne demandez pas pourquoi ...


Redémarrez le Xcode, il devrait résoudre avant d'essayer les suggestions ci-dessus. C'est un truc classique qui semble fonctionner même aujourd'hui: P





application-loader