Fichiers de support manquants pour Xcode iOS 12.2(16E227)




(3)

Après avoir copié et renommé le dossier, si le problème persiste, redémarrez le Mac.

Mon appareil exécute iOS 12.2, mais la dernière version Xcode disponible (sur le magasin et directement auprès de developer.apple, qui me pousse simplement vers le magasin) ne fournit pas les fichiers de support de cette version iOS. Par conséquent, je ne peux pas créer de périphériques. .

Voici le message d'erreur de Xcode:

Et ma version Xcode fonctionnant sur macOS Mojava v.10.14:

Existe-t-il d'autres endroits réputés pour télécharger une version bêta Xcode plus récente (ou uniquement les fichiers de support, dans Xcode> Contenu> Développeur> Plates-formes> iPhoneOS.platform> DeviceSupport) ou manque-t-il quelque chose ici?


J'ai eu le même problème. J'étais sur le point de télécharger le https://github.com/iGhibli/iOS-DeviceSupport/blob/master/DeviceSupport/12.2%20(16E226).zip et de le coller dans le répertoire /Applications/Xcode.app/Contents/Developer/ Chemin d' accès Platforms / iPhoneOS.platform / DeviceSupport mais je pense que ce n'est pas le flux normal. Plus tard, je me suis rappelé que je ne téléchargeais presque jamais les mises à jour du système d'exploitation. Ma solution était:

  1. Allez à propos de ce mac -> Mise à jour logicielle (Mises à jour du système d'exploitation).
  2. Après avoir téléchargé et installé la mise à jour, vous pourrez mettre à jour Xcode.
  3. Allez sur App Store -> recherchez xcode et vous pourrez mettre à jour Xcode avec succès.

En conclusion: je devais installer des mises à jour pour mon système d'exploitation macOS.


Voici le fichier source .

Après avoir copié le dossier téléchargé dans /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport , redémarrez Xcode pour que cela fonctionne. J'espère que ceci vous aidera.





xcode