ios - Application archivée avec Xcode 11.2(11B52) rejetée: ITMS-90534: Chaîne d'outils non valide




app-store toolchain (2)

J'ai installé Catalina et Xcode 11 depuis le magasin et ils sont à jour:

  • Catalina: 10.15.1 (19B88)
  • Xcode: 11.2 (11B52)

Hier, j'ai téléchargé un nouveau fichier binaire à l'aide de fastlane . Aujourd'hui, j'ai reçu ce message d'Apple:

Cher développeur,

Nous avons identifié un ou plusieurs problèmes avec une soumission récente concernant l'examen de l'App Store pour votre application, "Gözen Security" 7.3.2 (67). Veuillez corriger les problèmes suivants, puis téléchargez à nouveau.

ITMS-90534: Chaîne d'outils non valide - Votre application a été créée avec une version non prise en charge de Xcode ou du SDK. Si vous envisagez de soumettre cette version à l'App Store, assurez-vous d'utiliser la version GM de Xcode 10.1 et du SDK pour iOS 12.1, ainsi que watchOS 5.1, Xcode 7.1 et le SDK pour tvOS 9, ou Xcode 6 et le SDK pour macOS. 10.9 ou plus tard. Si vous utilisez une version bêta Xcode pour tester votre application, assurez-vous que vous utilisez la dernière version prise en charge. Pour plus d'informations sur les versions bêta prises en charge, consultez la page Nouveautés de l'App Store Connect ( https://developer.apple.com/app-store-connect/whats-new/ ).

Meilleures salutations,

L'équipe App Store

Depuis la sortie officielle de Catalina et de Xcode 11 pourquoi Apple veut-il toujours que j'utilise Xcode 10 et iOS 12 ?



Vous devez modifier la chaîne d'outils à partir des paramètres Xcode . Vous pouvez le faire comme suit:

  1. Ouvrez " Xcode ".
  2. Dans le menu du haut, appuyez sur " Xcode -> Préférences ".
  3. Dans le menu ouvert, tapez sur " Emplacements> Outils de ligne de commande> Xcode 11.2 (11B52) ".

Remarque: Il peut y avoir plusieurs chaînes d'outils selon les versions de Xcode vous avez installées. Il est donc préférable de choisir la dernière version lors de la soumission des applications.

Dites-moi que cela aide ou pas?





macos-catalina