une - svn repository eclipse




Obtenir Subclipse dans Aptana pour travailler avec la dernière version de Subversion (3)

La version de Subclipse (1.2.4) actuellement disponible via le gestionnaire de plugins automatique d'Aptana ne fonctionne pas avec la dernière version de Subversion.

Je vois sur le site Web de Subclipse cependant qu'ils ont 1.4.2 dehors pour Eclipse. J'ai donc ajouté un nouveau site de mise à jour à distance à mon gestionnaire de mises à jour. Quand j'ai essayé de l'installer, il m'a dit que j'avais besoin de Mylyn 3.0.0 . Donc, après beaucoup de recherches, j'ai trouvé Mylyn 3.0.0 et ajouté un autre site de mise à jour à distance à mon gestionnaire de mise à jour. Puis quand j'ai essayé d'installer cela, il m'a dit que j'avais besoin de org.eclipse.ui 3.3.0 ou équivalent.

En regardant les détails de configuration pour Aptana, on dirait qu'il est construit contre éclipse 3.2.2.

Est-ce que quelqu'un sait s'il existe un moyen de mettre à niveau la version d'Eclipse Aptana qui est construite par rapport à 3.3.0? Ou s'il y a un autre moyen de faire fonctionner Subclipse avec la toute dernière version de Subversion?

Je sais que ce n'est pas nécessairement une question de «programmation», mais j'espère que c'est correct car c'est très pertinent pour l'expérience de programmation.


J'ai eu des problèmes avec JavaHL dans Eclipse Ganymede, quand ça fonctionnait bien dans Eclipse Europa. Je ne suis pas sûr de la différence entre Aptana, mais essayez de mettre à jour JavaHL ou de passer à l'implémentation de SVNKit pure-java dans la configuration de Subclipse.


J'ai utilisé l'URL de mise à jour et j'ai installé l'adaptateur JavaHL, le projet Subclipse lui - même et l'adaptateur SVNKit BETA.

Après cela, cela a fonctionné très bien pour moi, c'est pour plate-forme Linux espère que cela fonctionne pour vous.


Subclipse ne nécessite pas Mylyn, mais le site de mise à jour inclut un plugin qui intègre Mylyn et Subclipse. Ceci est destiné aux personnes qui utilisent Mylyn. Dans votre cas, vous souhaitez simplement désélectionner Mylyn dans la boîte de dialogue de mise à jour.

Subclipse nécessite également Subversion 1.5 et la version correspondante des bibliothèques natives JavaHL. J'ai écrit le début d'une FAQ pour aider les gens à comprendre JavaHL et comment l'obtenir. Voir: http://desktop-eclipse.open.collab.net/wiki/JavaHL





subclipse