Terraform 0.11 - Terraform Configuration

टेराफॉर्म कॉन्फ़िगरेशन




terraform

टेराफॉर्म कॉन्फ़िगरेशन

terraform कॉन्फ़िगरेशन अनुभाग का उपयोग टेराफ़ॉर्म को स्वयं कॉन्फ़िगर करने के लिए किया जाता है, जैसे कॉन्फ़िगरेशन को निष्पादित करने के लिए न्यूनतम टेराफ़ॉर्म संस्करण की आवश्यकता होती है।

यह पृष्ठ मानता है कि आप पहले से ही विन्यास वाक्य रचना से परिचित हैं।

उदाहरण

टेराफॉर्म कॉन्फ़िगरेशन निम्नलिखित की तरह दिखता है:

terraform {
  required_version = "> 0.7.0"
}

विवरण

terraform ब्लॉक terraform के व्यवहार को स्वयं कॉन्फ़िगर करता है।

वर्तमान में इस ब्लॉक के भीतर केवल स्वीकृत कॉन्फ़िगरेशन required_version backend और backend

required_version version संस्करण अवरोधों का एक सेट निर्दिष्ट करता है जो इस कॉन्फ़िगरेशन पर कार्रवाई करने के लिए मिलना चाहिए। यदि चल टेराफ़ॉर्म संस्करण इन बाधाओं को पूरा नहीं करता है, तो एक त्रुटि दिखाई जाती है। इस विकल्प के लिए समर्पित अनुभाग नीचे देखें।

backend कॉन्फ़िगरेशन पर अधिक विवरण के लिए backends देखें।

terraform ब्लॉक के भीतर कोई मूल्य प्रक्षेपों का उपयोग नहीं कर सकता है। terraform के निष्पादन में टैराफॉर्म ब्लॉक को बहुत पहले से लोड किया जाता है और इंटरपोलेशन अभी तक उपलब्ध नहीं हैं।

एक आवश्यक Terraform संस्करण निर्दिष्ट करना

आवश्यक_version सेटिंग का उपयोग Terraform के विशिष्ट संस्करण की आवश्यकता के लिए किया जा सकता है। यदि Terraform का रनिंग संस्करण निर्दिष्ट बाधाओं से मेल नहीं खाता है, तो Terraform एक त्रुटि और निकास दिखाएगा।

जब modules का उपयोग किया जाता है, तो पूर्ण मॉड्यूल ट्री द्वारा निर्दिष्ट सभी टेराफॉर्म संस्करण आवश्यकताओं को संतृप्त किया जाना चाहिए। इसका मतलब यह है कि आवश्यक_version सेटिंग का उपयोग एक मॉड्यूल द्वारा किया जा सकता है ताकि यह सुनिश्चित हो सके कि मॉड्यूल के सभी उपभोक्ता एक विशिष्ट संस्करण का भी उपयोग करते हैं।

इस कॉन्फ़िगरेशन का मान अवरोधों की अल्पविराम से अलग की गई सूची है। एक बाधा एक ऑपरेटर है जिसके बाद एक संस्करण है, जैसे कि > 0.7.0 । बाधाएं निम्नलिखित कार्यों का समर्थन करती हैं:

  • = (या कोई ऑपरेटर नहीं): सटीक संस्करण समानता

  • != !: संस्करण नहीं के बराबर

  • > , >= , < , <= : संस्करण तुलना, जहां "से अधिक" एक बड़ा संस्करण संख्या है

  • ~> : निराशावादी बाधा ऑपरेटर। उदाहरण: ~> 0.9 , इसका मतलब है >= 0.9, < 1.0 । उदाहरण: ~> 0.8.4 , इसका अर्थ है >= 0.8.4, < 0.9

मॉड्यूल के लिए, एक न्यूनतम संस्करण की सिफारिश की जाती है, जैसे कि > 0.8.0 । यह न्यूनतम संस्करण यह सुनिश्चित करता है कि एक मॉड्यूल उम्मीद के मुताबिक काम करता है, लेकिन नए संस्करणों का उपयोग करने के लिए उपभोक्ता को लचीलापन देता है।

वाक्य - विन्यास

पूर्ण वाक्यविन्यास है:

terraform {
  required_version = VALUE
}