ios stores हेल्थकिट के साथ आईओएस सार्वभौमिक ऐप आईपैड पर नहीं चलेगा




iphone store app (3)

मेरे पास एक सार्वभौमिक ऐप है और मैंने इसे हेल्थकिट एपीआई का उपयोग करने के लिए लागू किया है। यह आईफोन पर बहुत अच्छा चलता है लेकिन जब मैं इसे एक वास्तविक आईपैड डिवाइस पर स्थापित करने का प्रयास करता हूं (आईपैड सिम्युलेटर में पूरी तरह से काम करता है) तो यह इंस्टॉल नहीं होगा।

मुझे त्रुटि संदेश मिल रहा है: "जानकारी के लिए Info.plist ... डिवाइस क्षमता आवश्यकताओं को निर्दिष्ट करता है, जो" मेरे आईपैड "से नहीं मिलते हैं"।

क्या मैं किसी भी तरह से एक सार्वभौमिक ऐप वितरित कर सकता हूं जहां हेल्थकिट एपीआई (ढांचा) केवल आईफोन पर ही चलती है?

मेरे प्रोजेक्ट के दो स्क्रीनशॉट हैं:

क्या मुझे वास्तव में एक स्टैंडअलोन आईपैड ऐप बनाने की ज़रूरत है?


आप अपने प्रोजेक्ट की info.plist में "आवश्यक डिवाइस क्षमताओं" से हेल्थकिट निकाल सकते हैं


ऐसा लगता है कि आप आईपैड पर हेल्थकिट का उपयोग नहीं कर सकते हैं:

हेल्थकिट फ्रेमवर्क संदर्भ से:

आईपैड पर हेल्थकिट और हेल्थ ऐप दोनों अनुपलब्ध हैं। हेल्थकिट ढांचे का उपयोग ऐप एक्सटेंशन में नहीं किया जा सकता है।


ऐप्पल दस्तावेज से: https://developer.apple.com/reference/healthkit

आईपैड पर हेल्थकिट और हेल्थ ऐप अनुपलब्ध है

जब आप किसी आईओएस ऐप पर हेल्थकिट क्षमताओं को सक्षम करते हैं, तो एक्सकोड आवश्यक डिवाइस क्षमताओं की सूची में हेल्थकिट जोड़ता है। यह उपयोगकर्ताओं को उन डिवाइसों पर ऐप खरीदने या इंस्टॉल करने से रोकता है जो हेल्थकिट का समर्थन नहीं करते हैं

दोनों बयान एक साथ बताते हैं कि यदि आप अपने ऐप में हेल्थकिट क्षमताओं को जोड़ते हैं, तो उपयोगकर्ता आपके ऐप को आईपैड पर इंस्टॉल नहीं कर पाएंगे।

यह डिवाइस संगतता मैट्रिक्स में भी पाया जा सकता है: https://developer.apple.com/library/content/documentation/DeviceInformation/Reference/iOSDeviceCompatibility/DeviceCompatibilityMatrix/DeviceCompatibilityMatrix.html





health-kit