ios आईओएस 9 डिवाइस के साथ एक्सकोड 7 त्रुटि: डिवाइस अनुपलब्ध(डेवलपर डिस्क छवि नहीं मिल सका)




xcode ipad (8)

ऐप्पल ने अभी नया एक्सकोड 7.1 जारी किया जो आईओएस 9.1 का समर्थन करता है। अपना एक्सकोड अपडेट करें और सब ठीक हो जाएगा।

आईओएस 9 सार्वजनिक बीटा में अपना आईपैड अपडेट करने के बाद, मुझे अपने आईपैड में ऐप चलाने की कोशिश करते समय एक त्रुटि मिल रही है। जब मैं आईपैड को गंतव्य के रूप में चुनता हूं, तो यह कहता है "आईपैड (अनुपलब्ध) या डेवलपर डिस्क छवि नहीं मिल सका। मैं इसे कैसे ठीक कर सकता हूं? कोई समाधान?


मेरे पास एक्सकोड 7.0.1 स्थापित + आईओएस 9.1 (13 बी 143) था।

जब तक मैंने अपने एक्सकोड को संस्करण 7.1 में अपडेट नहीं किया, तब तक एक्सकोड ने मुझे "असमर्थित डिवाइस" / "डेवलपर डिस्क छवि नहीं मिल सका" डिवाइस विंडो में दिखाया था। सबकुछ अब अच्छा काम करता है।


मैंने एक ही समस्या का अनुभव किया है

डेवलपर डिस्क छवि नहीं मिल सका

1) मेरा Xcode version was 7.0.1 और मैंने अपने iPhone to version 9.2 अपडेट किया, फिर एक्सकोड का उपयोग करने पर मेरा आईफोन अनुपलब्ध डिवाइस के खंड में दिखाया गया था। बस नीचे दी गई छवि की तरह:

2) लेकिन फिर मैंने किसी भी तरह से क्लिक करके अपने आईफोन का चयन करने में कामयाब रहे
उत्पाद -> गंतव्य -> ​​अनुपलब्ध डिवाइस

3) लेकिन यह मेरी समस्या का समाधान नहीं करता है और दिखाना शुरू कर देता है

डेवलपर डिस्क छवि नहीं मिल सका

समाधान) अंततः मैंने https://developer.apple.com/downloads/ से Xcode version 9.2 का नवीनतम संस्करण डाउनलोड किया और सब कुछ मेरे लिए ठीक काम किया।


यदि आप एक्सकोड 7 जीएम बिल्ड संस्करण 7 ए 218 का उपयोग कर रहे हैं, संभावना है कि आपने आईओएस 9 जीएम बिल्ड ( 13 ए 340 ) के विरोध में गलती से आईओएस 9.1 ( 13 बी 5110e ) डाउनलोड किया है। मैंने वही काम किया चिंता मत करो। वे डाउनलोड पेज पर एक दूसरे के बहुत करीब हैं: 0

आप बस अपने डिवाइस पर कौन से संस्करण को अपने डिवाइस सेटिंग्स> सामान्य> बारे में> संस्करण पर जाकर देख सकते हैं

आपको बस इतना करना है कि सही आईओएस 9 जीएम बिल्ड download करें और आईट्यून्स पर जाएं। अपने डिवाइस पर क्लिक करें। सारांश टैब में, विकल्प + राइट क्लिक करें "अपडेट के लिए जांचें" और आईओएस 9 जीएम बिल्ड खोजक स्थान पर नेविगेट करके अपने डिवाइस को पुनर्स्थापित करें। "अपडेट के लिए जांचें" चुनकर नोट करें, आप अपने डिवाइस पर कोई भी सेटिंग या डेटा नहीं खोलेंगे। दूसरे शब्दों में, यह एक बहाली नहीं है

हालांकि, यदि आप एक्सकोड 7.1 बिल्ड संस्करण ( 7 बी 60 ) आईओएस 9.1 का उपयोग कर रहे हैं तो समर्थित है


मुझे एक ही समस्या थी और मुझे बस इतना करना था कि मेरा एक्सकोड 7.1 पर अपडेट किया जाए। उसके बाद यह काम किया। आपके एक्सकोड को नवीनतम संस्करण में अपडेट किया जाना है।


एक्सकोड अपडेट करें । अगर यह मदद नहीं करता है: जाओ

/Applications/Xcode-beta.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport

यदि आपको अपना डिवाइस आईओएस संस्करण नहीं मिला है, तो आप पिछले एक को कॉपी करने का प्रयास कर सकते हैं और जिसकी आपको आवश्यकता है उसका नाम बदल सकते हैं, एक्सकोड को पुनरारंभ करें और संकलित करने का प्रयास करें, यह मेरे लिए काम करता है।


मैं पहले से ही नवीनतम संस्करण एक्सकोड (7.0.1) में अपडेट कर चुका हूं लेकिन आईओएस 9.1 (13 बी 143) में आईपॉड टच 5 पर अभी भी निर्माण नहीं कर सकता। एक्सकोड में मेरे सहयोगी से डिवाइससमूप फ़ोल्डर में कॉपी 9.1 (13 बी 137) फ़ोल्डर के बाद, यह काम करता है! यकीन नहीं है कि यह कुछ दुष्प्रभाव पैदा करेगा।


आईओएस 9.0.एक्स डिवाइस के खिलाफ एक्सकोड 6.4 का उपयोग करने का प्रयास करते समय यह भी सामना किया जाता है। यहां बताया गया है कि आप इसे कैसे काम कर सकते हैं और अपने आईओएस 9.0.एक्स डिवाइस को पहचानने के लिए एक्सकोड 6.4 प्राप्त कर सकते हैं:

  1. एक्सकोड 7.0.1 डाउनलोड करें:

http://developer.apple.com/devcenter/download.action?path=/Developer_Tools/Xcode_7.0.1/Xcode_7.0.1.dmg

  1. Xcode_7.0.1.dmg खोलें और Xcode.app को अपने डेस्कटॉप पर खींचें

  2. राइट-क्लिक करें, पैकेज सामग्री दिखाएं, /Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport में नेविगेट करें

  3. अपने एक्सकोड 6.4 इंस्टॉल के लिए "9.0 (13 ए 340)" निर्देशिका को मौजूदा डिवाइससपोर्ट निर्देशिका में कॉपी करें। उदाहरण के लिए: ~ / अनुप्रयोग / एक्सकोड.एप / सामग्री / डेवलपर / प्लेटफार्म / आईफोनओएस.प्लाफार्म / डिवाइस समर्थन

  4. Xcode 6.4 को पुनरारंभ करें (यदि यह चल रहा था), और आपके डिवाइस को आईओएस 9.0.x चलाना अब एक मान्यता प्राप्त डिवाइस के रूप में दिखाना चाहिए।





ipad