ios - "डेवलपर डिस्क छवि नहीं मिल सका"




iphone xcode (6)

1) मैंने एक ही मुद्दे का अनुभव किया है, मेरा Xcode संस्करण 7.0.1 था , और मैंने अपने iPhone को 9.2 संस्करण में अद्यतन किया, फिर Xcode का उपयोग करने पर, मेरा iPhone अनुपलब्ध डिवाइस के अनुभाग में दिखाया गया। नीचे की छवि की तरह:

2) लेकिन फिर मैं किसी तरह क्लिक करके अपने iPhone का चयन करने में कामयाब रहा
उत्पाद -> गंतव्य -> ​​अनुपलब्ध डिवाइस

3) लेकिन इससे मेरी समस्या हल नहीं हुई, और यह प्रदर्शित होने लगी:

डेवलपर डिस्क छवि नहीं मिली

समाधान) फिर अंत में मैंने here से Xcode संस्करण 7.2 का नवीनतम संस्करण डाउनलोड किया और मेरे लिए सब कुछ ठीक रहा।

अद्यतन: जब भी iPhone डिवाइस का संस्करण Xcode के संस्करण से अधिक होता है, तो आप एक ही समस्या का अनुभव कर सकते हैं, इसलिए आपको इस त्रुटि को दूर करने के लिए अपने Xcode संस्करण को अपडेट करना चाहिए।

हाल ही में मुझे त्रुटि मिली है: "डेवलपर डिस्क छवि नहीं ढूंढ सका"

मुझे लगता है कि ऐसा तब से है जब मैंने iPhone पर iOS को 9.1 तक अपडेट किया है। मैं समस्या को कैसे ठीक कर सकता हूं और Xcode को iOS 9.1 उपकरणों का समर्थन कर सकता हूं?


Xcode 7.0.1 और iOS 9.1 असंगत हैं। आपको मैक ऐप स्टोर के माध्यम से Xcode के अपने संस्करण को अपडेट करना होगा।

यदि आपका iOS संस्करण कम है तो दूसरी ओर Xcode संस्करण है, आप सामान्य सेटिंग में जाकर iOS के निचले संस्करण के लिए परिनियोजन लक्ष्य को बदल सकते हैं और परिनियोजन के अंतर्गत अपना परिनियोजन लक्ष्य निर्धारित कर सकते हैं:

ध्यान दें:

Xcode 7.1 में iOS 9.2 बीटा एसडीके शामिल नहीं है। Xcode वेबसाइट से डाउनलोड करके Xcode को 7.2 बीटा में अपग्रेड किया गया।


पुराने XCode संस्करण में नए iOS संस्करण के लिए कोई डेवलपर डिस्क छवि नहीं है । यदि आप XCode को अपग्रेड नहीं करना चाहते हैं, तो आप इस उत्तर में नवीनतम संस्करणों के लिए तैयार डेवलपर डिस्क चित्र पा सकते हैं: https://.com/a/39865199/286361


बस अद्यतन Xcode। मेरी समस्या का समाधान किया


मैं Xcode 7.3 and my device version is iOS 10 पर उसी मुद्दे का सामना कर रहा हूं Xcode 7.3 and my device version is iOS 10

यह त्रुटि तब दिखाई जाती है जब आपका Xcode पुराना होता है और आपके द्वारा उपयोग किए जा रहे संबंधित उपकरण को नवीनतम संस्करण में अपडेट किया जाता है। सबसे पहले, नवीनतम Xcode संस्करण स्थापित करें।

हम निम्न चरणों का पालन करके इस समस्या को हल कर सकते हैं: -

  • खोजक खोलें अनुप्रयोग चुनें
  • Xcode 8 पर राइट क्लिक करें, "Show Package Contents", "Contents", "Developer", "Platforms", "iPhoneOS.Platform", "Device Support" चुनें।
  • 10.0 फ़ोल्डर (या बाद के संस्करण के लिए ऊपर) की प्रतिलिपि बनाएँ।
  • खोजक में वापस फिर से आवेदन का चयन करें
  • Xcode 7.3 पर राइट क्लिक करें, "Show Package Contents", "Contents", "Developer", "Platforms", "iPhoneOS.Platform", "Device Support" चुनें।
  • 10.0 फ़ोल्डर पेस्ट करें

यदि सब कुछ ठीक से काम करता है, तो आपके Xcode में एक नई डेवलपर डिस्क छवि है। अब खोजक बंद करें, और अपना Xcode छोड़ दें। अपना Xcode खोलें और त्रुटि दूर हो जाएगी। अब आप अपने नवीनतम डिवाइस को पुराने Xcode संस्करणों से जोड़ सकते हैं।

धन्यवाद


यदि आप अपने iOS10 डिवाइस पर Xcode 7 के साथ विकसित करना चाहते हैं:
(नोट: आप इस आदेश को अन्य Xcode और iOS संस्करणों के लिए अनुकूलित कर सकते हैं)

  1. अपना Xcode.app नाम बदलकर Xcode7.app करें और ऐप स्टोर से Xcode 8 डाउनलोड करें।
  2. इसे स्थापित करने के लिए एक बार Xcode 8 चलाएं।
  3. टर्मिनल खोलें और इस कमांड का उपयोग करके Xcode 8 डेवलपर डिस्क छवि 10.0 से Xcode 8 डेवलपर डिस्क छवि फ़ोल्डर का एक प्रतीकात्मक लिंक बनाएं:

    ln -s /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/10.0\ \(14A345\)/ /Applications/Xcode7.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/10.0

Source





ios9.1