Cassandra 3.0.0 के साथ फेसबुक प्रेस्टन 0.131 का उपयोग करने का कोई तरीका है?



prestodb cassandra-3.0 (1)

प्रेस्सियो 0.131 का उपयोग करते हुए Cassandra 3.0.0 क्लस्टर की क्वेरी करते समय मुझे मिलते हैं:

क्वेरी के लिए सभी मेजबानों ने प्रयास किया [..snip ...] InvalidQueryException: unconfigured table schema_keyspaces

मैं मानता हूं कि यह कैसांद्रा की सिस्टम स्कीमा में कुछ बदलाव के कारण है? यदि ऐसा है तो कोई वैकल्पिक हल है या क्या हमें क्रेस्ट्रा 3.0.0 का समर्थन करने के लिए प्रेस्टन की प्रतीक्षा करनी चाहिए?

2016-11-05 अपडेट : क्रेस्ट्रा 3+ के साथ प्रीस्टोडडीबी के नए संस्करण ठीक काम करते हैं। वर्तमान में 0.147 का उपयोग कर रहा है लेकिन नवीनतम संस्करण 0.156 है और ये सभी नए प्रोटोकॉल के साथ ठीक काम करते हैं। आपके उत्तर के लिए धन्यवाद


हाँ आप सही ढंग से अनुमान लगाया है - Cassandra 2.2.4 और 3.0.0 के बीच स्कीमा संग्रहण में एक बदलाव आया था। अधिक जानकारी के लिए यहां देखें। स्कीमा में वास्तविक परिवर्तन इस समस्या में वर्णित है।