android - त्रुटि संदेश प्राप्त करना "com.google.gms नहीं मिल सका: google-services: 2.0.0-alpha6।"




google-analytics (2)

निर्भरता के beta5 संस्करण को एक कोशिश दें:

classpath 'com.android.tools.build:gradle:2.0.0-beta5'
classpath 'com.google.gms:google-services:2.0.0-beta5'

Google Analytics क्विकस्टार्ट प्रोजेक्ट एक काम कर रहे एंड्रॉइड ऐप है और इसमें build.gradle उदाहरण शामिल हैं।

मैं अपनी परियोजना में Google विश्लेषणात्मक की कोशिश कर रहा हूं लेकिन build.gradle फ़ाइल बदलने के बाद निम्न त्रुटि संदेश मिला।

त्रुटि: com.google.gms नहीं मिल सका: google-services: 2.0.0-alpha6 निम्नलिखित स्थानों में खोज की: फ़ाइल: /home/vaibhav/android-studio/gradle/m2repository/com/google/gms/google-services/2.0.0-alpha6/google-services-2.0.0-alpha6.pom फ़ाइल: /home/vaibhav/android-studio/gradle/m2repository/com/google/gms/google-services/2.0.0-alpha6/google-services-2.0.0-alpha6.jar https://repo1.maven.org/ maven2 / com / google / gms / google-services / 2.0.0-अल्फा 6 / google-services-2.0.0-alpha6.pom https://repo1.maven.org/maven2/com/google/gms/google-services /2.0.0-alpha6/google-services-2.0.0-alpha6.jar द्वारा आवश्यक:: सामग्रीटैब -मास्टर: अनिर्दिष्ट

जहां मैं 1. अपने प्रोजेक्ट-स्तरीय build.gradle पर निर्भरता जोड़ें:

क्लासपाथ 'com.google.gms: google-services: 2.0.0-alpha6'

2. अपने ऐप-स्तरीय build.gradle में प्लगइन जोड़ें:

प्लगइन लागू करें: 'com.google.gms.google-services'

तथा

  1. Google Play सेवाओं के लिए एक निर्भरता जोड़ें अंदर का निर्माण जोड़ें:

comp.google 'com.google.android.gms: play-services-analytics: 8.4.0'

अग्रिम में धन्यवाद।


मेरे जैसी समस्या थी, और आपने टिम सॉंग के उत्तर से जुड़ा Google Analytics क्विकस्टार्ट प्रोजेक्ट को देखा था, मुझे लगता है कि आप jcenter() रिपॉजिटरी को याद कर रहे हैं जैसा मैं था।

JCenter अब एंड्रॉइड के ग्रेडले प्लगइन [0] के साथ उपयोग किए जाने वाले डिफ़ॉल्ट रिपॉजिटरी है, लेकिन पुराने प्रोजेक्ट को mavenCentral() का उपयोग डिफ़ॉल्ट रिपॉज़िटरी के रूप में किया गया था, जिसमें कोई भी mavenCentral() सेवाओं नहीं है

आपका build.gradle चाहिए

repositories {
    ...
    jcenter()
}
dependencies {
    ...
    classpath 'com.android.tools.build:gradle:2.0.0-beta6'
    classpath 'com.google.gms:google-services:2.0.0-beta6'
}

(मैंने 5 से 6 तक बीटा संस्करण को भी अपडेट किया है, लेकिन यह केवल यथासंभव वर्तमान का उत्तर देना है)

उम्मीद है की वो मदद करदे

[0] - http://blog.bintray.com/2015/02/09/android-studio-migration-from-maven-central-to-jcenter/





google-analytics