angularjs - मैं npm UNETET PEER DEPENDENCY चेतावनी को कैसे ठीक करूँ?




node.js angular-material (7)

npm अब सहकर्मी निर्भरता स्थापित नहीं करता है, इसलिए आपको उन्हें मैन्युअल रूप से स्थापित करने की आवश्यकता है, बस एक npm install आवश्यक डिपो पर npm install करें, और फिर मुख्य एक को फिर से स्थापित करने का प्रयास करें।

टिप्पणी का उत्तर दें:

यह उस संदेश में सही है, यह कहता है कि आपको याद आ रही है

UNMET PEER DEPENDENCY angular-[email protected]^1.5.0 +-- 
UNMET PEER DEPENDENCY angular-[email protected]^1.5.0 +-- angular-[email protected].0.6 +
UNMET PEER DEPENDENCY angular-[email protected]^1.5.0 `-- [email protected].4.57` 

तो आपको npm install angular angular-animate angular-aria angular-material angular-messages mdi करने की आवश्यकता है

मैं विंडोज 10 पर हूँ, नोड 5.6.0 और एनपीएम 3.6.0 के साथ। मैं अपने काम करने वाले फ़ोल्डर में कोणीय-सामग्री और एमडीए स्थापित करने की कोशिश कर रहा हूं। npm स्थापित करें:

+-- [email protected].5.0

+-- UNMET PEER DEPENDENCY angular-[email protected]^1.5.0

+-- UNMET PEER DEPENDENCY angular-[email protected]^1.5.0

+-- angular-[email protected].0.6

+-- UNMET PEER DEPENDENCY angular-[email protected]^1.5.0 `-- [email protected].4.57

npm WARN enoent ENOENT: no such file or directory, open
'C:\Users\xxxxx\Desktop\ngClassifieds\package.json' 

npm WARN angular-[email protected].0.6 requires a peer of
angular-[email protected]^1.5.0 but none was installed. 

npm WARN angular-[email protected].0.6 requires a peer of angular-[email protected]^1.5.0
but none was installed. 

npm WARN angular-[email protected].0.6 requires a peer of
angular-[email protected]^1.5.0 but none was installed.

AngularJS Material और MDI स्थापित करने के लिए मैं इसे कैसे हल करूं?


आज उपलब्ध Angular 2 rc.7 , और मुझे [email protected] UNMET PEER DEPENDENCY के साथ इसी तरह की समस्या थी।

यदि आप, मेरी तरह, बस @angular/...rc.6 को @angular/...rc.7 से बदल दिया है - यह पर्याप्त नहीं है। क्योंकि, उदाहरण के लिए, @angular/router का कोई rc.6 संस्करण नहीं है।

इस मामले में, क्विक स्टार्ट में बेहतर रिव्यू package.json


इस त्रुटि के सबसे संभावित कारणों में से एक यह हो सकता है कि आपने अपने पैकेज में पुराने संस्करण को परिभाषित किया हो। इस समस्या को हल करने के लिए, पैकेज में संस्करणों को बदलें। उन npm से मेल खाने के लिए शिकायत करें।

एक बार किया, npm स्थापित और वॉइला चलाने !!


ठीक है, तो मैं लंबे समय से यह पता लगाने की कोशिश कर रहा था। यहाँ परमाणु विकल्प है, जब आप अन्य सभी तरीकों से थक चुके हैं।

  • अपने पीसी पर एक नया फ़ोल्डर बनाएं।
  • कोणीय की एक नई स्थापना डाउनलोड करें - मैंने इस गाइड का उपयोग किया: https://coursetro.com/posts/code/55/How-to-Install-an-Angular-4-App
  • इसे चलाएं, सुनिश्चित करें कि यह काम करता है
  • फिर अपने पैकेज.जॉन फ़ाइल से एक-एक करके अपनी निर्भरताएं स्थापित करें
  • प्रत्येक स्थापित होने के बाद इसे चलाएं

जब आप कर रहे हैं, और यह अभी भी काम करता है, अपने वास्तविक कोड को इस नई परियोजना में आयात करें। किसी भी संकलन त्रुटियों को कोणीय कारणों के नए संस्करण को ठीक करें।

Thats यह मेरे लिए क्या किया .. wtf पता लगाने की कोशिश कर के 6 घंटे बनाम rework के 1 घंटे गलत था .. काश मैं इसे शुरू करने के लिए इस तरह से किया ..


मेरे मामले में सभी निर्भरताएँ पहले से ही थीं। कृपया एनपीएम को उस स्थिति में अपडेट करें क्योंकि यह दुर्घटनाग्रस्त हो गया होगा। इसने मेरी समस्या हल कर दी।

npm install -g npm

यह उत्तर सभी मामलों पर लागू नहीं होता है, लेकिन यदि आप केवल npm install टाइप करके त्रुटि को हल नहीं कर सकते हैं, तो यह कदम मदद कर सकता है।

मान लीजिए कि आपको यह त्रुटि मिली है।

UNMET PEER DEPENDENCY [email protected].2.0

npm WARN [email protected].3.0 requires a peer of [email protected]^3.1.0 but none was installed.

इसका मतलब है कि आपने पैकेजए के संस्करण 4.2.0 को स्थापित किया है, लेकिन पैकेजबी@3.3.0 को पकागेए के संस्करण 3.xx की आवश्यकता है। ( ^ का स्पष्टीकरण )

तो आप इस त्रुटि को 3.xx में पैकेजए को अपग्रेड करके हल कर सकते हैं, लेकिन आमतौर पर आप पैकेज को डाउनग्रेड नहीं करना चाहते हैं।
अच्छी खबर यह है कि कुछ मामलों में, पैकेजब सिर्फ पैकेजए के साथ नहीं रख रही है और पैकेजब के अनुरक्षक पैकेजए के सहकर्मी निर्भरता को 4.xx तक बढ़ाने के लिए कड़ी मेहनत कर रहे हैं
उस स्थिति में, आप देख सकते हैं कि पैकेजब का एक उच्च संस्करण है जिसे एनपीएम या जीथब में पैकेजए के संस्करण 4.2.0 की आवश्यकता है।

उदाहरण के लिए, रिलीज़ पृष्ठ पर जाएं

अक्सर आप इस तरह निर्भरता के बारे में ब्रेकिंग परिवर्तन पा सकते हैं।

packageB v4.0.0-beta.0

BREAKING CHANGE
package: requires packageA >= v4.0.0

यदि आपको रिलीज़ पृष्ठ पर कुछ भी नहीं मिलता है, तो पृष्ठ पर जाएं और peer जैसे कीवर्ड द्वारा समस्या खोजें। आपको उपयोगी जानकारी मिल सकती है।

इस बिंदु पर, आपके पास दो विकल्प हैं।

1) अपने इच्छित संस्करण पर अपग्रेड करें
2) समय के लिए त्रुटि छोड़ दें, स्थिर संस्करण जारी होने तक प्रतीक्षा करें।

यदि आप विकल्प 1 चुनते हैं:
कई मामलों में, संस्करण में latest tag नहीं है, इसलिए स्थिर नहीं है। इसलिए आपको यह जांचना होगा कि इस अपडेट में क्या बदलाव आया है और सुनिश्चित करें कि कोई भी चीज जीत नहीं पाएगी।

यदि आप विकल्प 2 चुनते हैं:
यदि संस्करण 3 से 4 तक पकागे का उन्नयन तुच्छ है, या यदि पकागेब के अनुरक्षक ने पकागेए के संस्करण 4 का परीक्षण नहीं किया है, लेकिन कहते हैं कि यह कोई समस्या नहीं होनी चाहिए, तो आप त्रुटि छोड़ने पर विचार कर सकते हैं।

दोनों ही मामलों में, यह पूरी तरह से परीक्षण करने के लिए सबसे अच्छा है अगर यह कुछ भी नहीं तोड़ता है।

अंत में, यदि आप जानते हैं कि आपको मैन्युअल रूप से ऐसा क्यों करना है, तो यह लिंक अच्छी तरह से समझाता है।


UNMET PEER DEPENDENCY त्रुटि तब डाली जाती है जब package.json में निर्दिष्ट एक या एक से अधिक मॉड्यूल की निर्भरता होती है। UNMET PEER DEPENDENCY फाइल पूरी नहीं होती है। चेतावनियों को ध्यान से देखें और निर्भरता के सही संस्करणों के साथ package.json फ़ाइल को अपडेट करें।

फिर भागो

rm -rf node_modules/
npm cache clean
npm install

यह सभी आवश्यक निर्भरता को सही ढंग से स्थापित करेगा।






angularjs-material