extjs - 4 से 6 तक मेरा एक्स्टजेस एप्लिकेशन कैसे बढ़ाएं?




migration upgrade (2)

आप सीएमडी उपकरण का उपयोग कर से बच सकते हैं और पूरी लाइब्रेरी स्रोतों से मैन्युअल रूप से लिंक कर सकते हैं, अगर आप यही पूछ रहे हैं। यह संभवतः किसी मौजूदा Ext4 ऐप के लिए बॉक्स से बाहर काम नहीं करेगा यदि कुछ तोड़ने वाले परिवर्तन हो सकते हैं:

<head>
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no">

    <link rel="stylesheet" type="text/css" href="/ext/classic/theme-triton/resources/theme-triton-all.css">
    <link rel="stylesheet" type="text/css" href="/ext/packages/charts/classic/triton/resources/charts-all.css">
    <link rel="stylesheet" type="text/css" href="/ext/packages/ux/classic/triton/resources/ux-all.css">

    <script type="text/javascript" src="/ext/ext-all.js"></script>
    <script type="text/javascript" src="/ext/classic/theme-triton/theme-triton.js"></script>
    <script type="text/javascript" src="/ext/packages/charts/classic/charts.js"></script>
    <script type="text/javascript" src="/ext/packages/ux/classic/ux.js"></script>
</head>

अब मेरे आवेदन में मैं एक्स्टजे 4 का उपयोग कर रहा हूं और मैं इसे एक्जिज 6 में माइग्रेट करना चाहता हूं ताकि उत्तरदायी डिजाइन किया जा सके। लेकिन मेरे आवेदन सेन्चा सीएमडी द्वारा नहीं बनाया गया है, तो मैं उन्नयन के लिए इस उपकरण का उपयोग नहीं कर सकता। क्या यह केवल मेरे एचटीएमएल दृश्यों में इस संसाधन को बदलकर अपग्रेड करना संभव है:

<link rel="stylesheet" href="/css/ext-all.css"     />
<script type="text/javascript" src="/js/ext-4.1.1a/ext-all.js"  ></script>