मैकोड को अपडेट किए बिना मैं Xcode 9 कैसे स्थापित कर सकता हूं?




download xcode9 (3)

Xcode 8 बीटा 6 रिलीज नोट्स से :

Xcode 8 बीटा 6 को मैक रनिंग मैकोस सिएरा बीटा 3 या बाद के संस्करण, या ओएस एक्स एल कैपीटन 10.11.5 या बाद के संस्करण की आवश्यकता है।

मैकोज 10.10 एक असमर्थित कॉन्फ़िगरेशन है और यह Xcode 8 द्वारा समर्थित नहीं है। आपका एकमात्र समाधान 10.11 को अपडेट करना है।

क्या मैकोज़ को अद्यतन किए बिना किसी को Xcode 8 या Xcode 9 को स्थापित करने का कोई विचार है?

मैं अपने Xcode 7.1 को Xcode 9 (या 9.1 / 9.2) बीटा को अपडेट करना चाहता हूं।

लेकिन यह मुझे OS X Yosemite 10.10 पर सीधे अपडेट करने की अनुमति नहीं देता है।

और मैं अपने ओएस को अल कैपिटन में अपडेट नहीं करना चाहता, इसलिए मैं ओएस एक्स पर मौजूदा नवीनतम एक्सकोड कैसे स्थापित कर सकता हूं।


Xcode8 OSX10.11 (एल कैपिटन) पर काम करेगा, लेकिन आपके द्वारा बनाए गए ऐप्स नहीं होंगे, क्योंकि उपलब्ध एसडीके केवल मैकस 10.12 एसडीके है, अर्थात मैक्स सिएरा की।

रिलीज़ नोट्स से:

अनुकूलता

Xcode 8 को मैक रनिंग मैकोस सिएरा 10.12 या ओएस एक्स एल कैपिटन 10.11.5 या बाद के संस्करण की आवश्यकता है।

Xcode 8 में आईओएस 10.0, वॉचओएस 3.0, मैकोज सिएरा 10.12 और टीवीओएस 10.0 के लिए एसडीके शामिल हैं।


नवीनतम Xcode टूल का उपयोग करने के लिए आपको मैक ओएस अपडेट करना होगा।

ऐप्पल के अनुसार, Xcode 9 - रिलीज नोट , Xcode 9 को मैक रनिंग मैकोज 10.12.6 (सिएरा) या बाद के संस्करण की आवश्यकता है


नीचे दिए गए लिंक से आप पेड (प्रीमियम) एप्पल डेवलपर खाते के साथ Xcode 9 डाउनलोड कर सकते हैं।

Xcode 9


गैर-प्रीमियम खाते / सेब आईडी के लिए:

एपल डाउनलोड पोर्टल







xcode9.2