java - ईक्लिप्स नियॉन के लिए चेकस्टाइल-प्लगइन(7.2.0) इंस्टॉल करना विफल रहता है



eclipse plugins (1)

आपको जेरे सेक्टर में अपने नेटवर्क रूट SSL प्रमाणपत्र स्थापित करने की आवश्यकता है किसी भी जावा पीकेक्स एसएसएल एक्सपेंशन के लिए आप इस गाइड का अनुसरण कर सकते हैं।

रूट प्रमाणपत्र कैसे प्राप्त करें?

  1. Google क्रोम को खोलें और https://sourceforge.net/ पर जाएं
  2. अपने url के ठीक आइकन पर क्लिक करें निम्नलिखित चित्र देखें

  1. व्यू प्रमाणपत्र पर क्लिक करें। आप पदानुक्रम देख सकते हैं और पदानुक्रम में सबसे अधिक प्रमाण पत्र का चयन कर सकते हैं
  2. पुष्टि करें कि प्रमाणपत्र के नाम पर मूल शब्द हैं।
  3. अब बस उस पदानुक्रम के भाग को मान लें कि आप प्रमाण पत्र की एक आयताकार छवि देख सकते हैं। बस उस छवि को खींचें और उसे अपने डेस्कटॉप पर छोड़ दें

अब आप अपनी जड़ सर्टिफिकेट है!

कैसे इस प्रमाणपत्र को ज्रे कैक्टर्स में स्थापित करें?

आगे बढ़ने से पहले आप यह पुष्टि करते हैं कि आप इस त्रुटि को दे रहे जेरे के बिल्कुल ठीक से मौजूद थे। कई बार आईडीई जेआर का इस्तेमाल करता है जिसे सिस्टम जे्र के साथ बंडल किया जाता है। मेरे मामले में मैंने अपने सभी आईडीई को मेरे सिस्टम जावा अधिष्ठापन के लिए बताया।

  1. अपने जेरु बिन फ़ोल्डर के अंदर keytool.exe का उपयोग करें।
  2. cacerts फ़ाइल के अंदर अपने प्रमाण पत्र को रखने के लिए कमांड के बाद आग

keytool -import -noprompt -trustcacerts -alias ALIASNAME -file
/PATH/TO/YOUR/DESKTOP/CertificateName.cer-keystore / PATH / TO / YOUR / JDK / jre / lib / सुरक्षा / cacerts -storepass changeit

अब आपकी समस्या का समाधान है! अपनी पहचान को फिर से शुरू करें और परिणाम जांचें

मैंने अपने Eclipse for Java Developers ईक्लीपस बंडल Eclipse for Java Developers चेकस्टाइल-प्लगइन को स्थापित करने की कोशिश की, जो http://Eclipse-cs.sourceforge.net/#!/ पर दिए गए लिंक को मेरी एक्लिप्स विंडो पर खींचकर, खींच कर।

दुर्भाग्य से यह निम्न त्रुटि में परिणाम:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,net.sf.eclipsecs.branding,7.2.0.201611072237
No repository found containing: osgi.bundle,net.sf.eclipsecs.checkstyle,7.2.0.201611072237
No repository found containing: osgi.bundle,net.sf.eclipsecs.core,7.2.0.201611082201
No repository found containing: osgi.bundle,net.sf.eclipsecs.doc,7.2.0.201611082205
No repository found containing: org.eclipse.update.feature,net.sf.eclipsecs,7.2.0.201611082205
No repository found containing: osgi.bundle,net.sf.eclipsecs.ui,7.2.0.201611072237

किसी भी विचार मैं इसे कैसे ठीक कर सकता हूँ?

बाज़ार का उपयोग करके इसे स्थापित करना भी काम नहीं कर रहा था। इसके साथ असफल रहा:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at https://sourceforge.net/projects/eclipse-cs/files/updatesite/7.2.0/plugins/net.sf.eclipsecs.doc_7.2.0.201611082205.jar.
sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Unable to read repository at https://sourceforge.net/projects/eclipse-cs/files/updatesite/7.2.0/features/net.sf.eclipsecs_7.2.0.201611082205.jar.
sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target




plugins