angular - ctorParameters.map कोणीय 2-mdl में एक फ़ंक्शन नहीं है




angular-cli angular2-mdl (4)

मैं कोणीय-सीएलआई के साथ कोणीय 2-एमडीएल का उपयोग करने की कोशिश कर रहा हूं। मैंने MdlModule में MdlModule का आयात किया।

जब मैं <mdl-textfield type="text" label="Text..." floating-label></mdl-textfield> का उपयोग करने का प्रयास करता हूं, तो यह एक त्रुटि करता है:

ctorParameters.map कोणीय 2-mdl में एक फ़ंक्शन नहीं है

मुझे नहीं पता कि मुझे क्या करना चाहिए।

यहाँ मेरा कोणीय-cli.json है।

  "dependencies": {
    "@angular/common": "~2.0.0",
    "@angular/compiler": "~2.0.0",
    "@angular/core": "~2.0.0",
    "@angular/forms": "~2.0.0",
    "@angular/http": "~2.0.0",
    "@angular/material": "^2.0.0-alpha.9-3",
    "@angular/platform-browser": "~2.0.0",
    "@angular/platform-browser-dynamic": "~2.0.0",
    "@angular/router": "~3.0.0",
    "@types/moment-timezone": "^0.2.33",
    "angular-cli": "^1.0.0-beta.17",
    "angular2-jwt": "^0.1.25",
    "angular2-mdl": "^2.9.0",
    "bootstrap": "^3.3.7",
    "bourbon": "^4.2.7",
    "core-js": "^2.4.1",
    "font-awesome": "^4.7.0",
    "hammerjs": "^2.0.8",
    "moment": "^2.17.1",
    "moment-timezone": "^0.5.10",
    "node-sass": "^3.13.0",
    "primeng": "^1.1.0",
    "rxjs": "5.0.0-beta.12",
    "ts-helpers": "^1.1.1",
    "zone.js": "^0.6.23"
  },
  "devDependencies": {
    "@types/jasmine": "^2.2.30",
    "@types/moment": "^2.13.0",
    "@types/moment-timezone": "^0.2.33",
    "@types/node": "^6.0.42",
    "angular-cli": "1.0.0-beta.17",
    "bootstrap-sass": "^3.3.7",
    "codelyzer": "~0.0.26",
    "jasmine-core": "2.4.1",
    "jasmine-spec-reporter": "2.5.0",
    "karma": "1.2.0",
    "karma-chrome-launcher": "^2.0.0",
    "karma-cli": "^1.0.1",
    "karma-jasmine": "^1.0.2",
    "karma-remap-istanbul": "^0.2.1",
    "protractor": "4.0.9",
    "ts-node": "1.2.1",
    "tslint": "3.13.0",
    "typescript": "2.0.2"
  }

ऐसा लगता है कि इस प्रश्न को कुछ स्पष्टीकरण की आवश्यकता है:

हम इस त्रुटि संदेश को क्यों देखते हैं?

यदि कोणीय 2 के लिए एक घटक पुस्तकालय एओटी के साथ संगत होना चाहता है तो उसे एनजीसी (@ कोणीय / संकलक-क्ली) के साथ संकलित करने की आवश्यकता है। यह प्रत्येक घटक के लिए * .metadata.json फाइलें उत्पन्न करेगा। इसके अलावा यह प्रत्येक घटक के लिए जेएस फाइलें उत्पन्न करता है जिसमें कंस्ट्रक्टर मापदंडों के बारे में जानकारी शामिल है। यदि पैकेज @ कोणीय / संकलक-क्ली <2.3.0 के संस्करण के साथ संकलित किया गया था तो यह होगा (उदाहरण के लिए):

MdlBadgeDirective.ctorParameters = [
        { type: ElementRef, },
        { type: Renderer, },
];

यदि पैकेज एक नए संस्करण के साथ संकलित किया जाता है तो यह होगा:

MdlBadgeDirective.ctorParameters = function () { return [
        { type: ElementRef, },
        { type: Renderer, },
]; };

जैसा कि आप देख सकते हैं कि नया संस्करण एक फ़ंक्शन है और अब कोई सरणी नहीं है। तो त्रुटि

ctorParameters.map एक फ़ंक्शन नहीं है

समझ में आता है। क्योंकि नक्शा सरणी का सदस्य है, लेकिन फ़ंक्शन का नहीं।

इस समस्या को हल कैसे करें?:

  1. आप अपने कोणीय संस्करणों (या संकुल जो आपके कोणीय 2 कोड को संकलित करने की कोशिश कर रहे हैं) को नए संकलक आउटपुट स्वरूप में अपडेट कर सकते हैं। जैसे कम से कम @angular / * @ 2.3.1। (यदि आप कोणीय-क्ली का उपयोग कर रहे हैं तो आपको अपनी परियोजना को कोणीय[email protected] पर अपग्रेड करना चाहिए)

  2. आप अपने द्वारा उपयोग किए जा रहे पैकेज को पुराने संकलक आउटपुट स्वरूप से मेल खाने वाले संस्करण पर लॉक कर सकते हैं। कोणीय 2-mdl के लिए यह संस्करण 2.7.0 है। आप यह जानकारी यहाँ पा सकते हैं: https://github.com/mseemann/angular2-mdl#remarks

क्या एक ऐसे पैकेज का उपयोग करना संभव है जो पुराने कोणीय-संकलक-क्ली के साथ एक नए कोणीय-संकलक-क्ली संस्करण के साथ संकलित किया गया था? (उदाहरण के लिए आप कोणीय 2.4.1 पर हैं और कोणीय [email protected] का उपयोग करना चाहते हैं) हाँ! यह दिशा पिछड़ी संगत है। https://github.com/angular/angular/blob/master/modules/%40angular/core/src/reflection/reflection_capabilities.ts#L80 देखें


कोणीय 2.4.6 के उन्नयन के बाद यह ठीक काम करता है

 "dependencies": {
    "@angular/common": "2.4.6",
    "@angular/compiler": "2.4.6",
    "@angular/compiler-cli":"2.4.6",
    "@angular/core": "^2.4.6",
    "@angular/forms": "2.4.6",
    "@angular/http": "2.4.6",
    "@angular/platform-browser":"2.4.6",
    "@angular/platform-browser-dynamic":"2.4.6",
    "@angular/platform-server":"2.4.6",
    "@ionic/storage": "1.1.6",
    "@types/jasmine": "2.5.37",
    "@types/moment-timezone": "^0.2.34",
    "@types/request": "0.0.33",
    "angular-qrcode": "^6.2.1",
    "angular2-fullcalendar": "^1.1.1",
    "angular2-qrcode": "^2.0.0",
    "angularfire2": "2.0.0-beta.6",
    "ionic-angular": "^2.0.0-201702062042",
    "ionic-native": "2.2.3",
    "ionicons": "3.0.0",
    "moment": "^2.17.0",
    "ng2-signalr": "^2.0.3",
    "rxjs": "5.1.0",
    "zone.js": "0.7.6"
  },

मेरा भी यही मुद्दा था। यह कारण था क्योंकि मैं उपयोग कर रहा था

"एनजी 2-बूटस्ट्रैप": "^ 1.3.1",

"@ कोणीय / आम": "2.0.1",

"@ कोणीय / संकलक": "2.0.1",

"@ कोणीय / कोर": "2.0.1",

"@ कोणीय / प्लेटफ़ॉर्म-ब्राउज़र": "2.0.1",

तब मैंने कोणीय निर्भरता को अद्यतन किया

"@ कोणीय / आम": "2.2.3",

"@ कोणीय / संकलक": "2.2.3",

"@ कोणीय / कोर": "2.2.3",

"@ कोणीय / प्लेटफ़ॉर्म-ब्राउज़र": "2.2.3",

यह ठीक काम किया।


मैं ng build से त्रुटि रिपोर्ट को देखकर इस मुद्दे का कारण जानने में सक्षम था:

npm WARN @angular/[email protected] requires a peer of @angular/[email protected] but none was installed.

इससे मुझे एहसास हुआ कि मेरे पैकेजों में से एक कोणीय को v2.4.4 पर होने की उम्मीद है, लेकिन मैं v2.0.1 का उपयोग कर रहा हूं। मैंने अपने पैकेज को अपडेट किया है। इस तरह दोनों पैकेजों को मेरे मुख्य संस्करण पर सेट किया है:

"dependencies": {
    "@angular/core": "2.0.1",
    "@angular/platform-server": "2.0.1",
}

आपका मुद्दा @ कोणीय / प्लेटफ़ॉर्म-सर्वर के साथ नहीं हो सकता है, लेकिन मुझे आशा है कि यह इसे डीबग करने में मदद करता है