ios - Xcode चेतावनी को हटाने के लिए कैसे करें एप्पल मैक- ओ लिंकर चेतावनी 'सूचक पते पर गठबंधन नहीं है




cocoapods warnings (4)

इन समस्याओं को संबोधित किया जाता है, और 3.16.0 रिहाई के साथ संभवतः तय हो गया है।

मेरे Xcode प्रोजेक्ट का निर्माण करते समय मेरे पास एक मामूली मुद्दा है, अपडेट पॉड के बाद चेतावनी का टोन मिलता है। यह इस तरह दिख रहा है

पहले से ही पूरी साइट यहां खोज रहे हैं लेकिन अभी भी कोई भाग्य नहीं है। यह परियोजना को प्रभावित नहीं करता है लेकिन यह काफी परेशान है कोई भी मदद कर सकता है?


इसका शायद मतलब है कि जब उनके कोड को संकलित करते हैं, तो उनकी बाइनरी फ़ाइल में गैर-गठबंधन सूचक होता है। उन मामलों में संरेखण मूलतः 1 बाइट के लिए डिफ़ॉल्ट और hypothetically प्रदर्शन को प्रभावित कर सकता है Xcode को अपडेट करने के बाद 8.3 सार्वजनिक रिलीज़ मैं अभी भी इस त्रुटि को देख रहा हूं, इसलिए Google को इसकी स्थैतिक लाइब्रेरी को अलग-अलग सेटिंग्स के साथ संकलित करने की आवश्यकता हो सकती है।


दोस्तों, यह सब अब तय हो गया है दो परियोजनाओं पर यह सब स्वयं का परीक्षण किया आपको अपनी प्रोजेक्ट की सही निर्देशिका पर जाना होगा ताकि आपकी पॉड स्पेक फाइल आपके कमांड लाइन कमांड के लिए दृश्यमान हो, चलें

pod update

और यह सब ठीक और ठीक से काम कर देखें!


फ़ायरबसे समर्थन से यह प्रतिक्रिया मिली:

यह Xcode 8.3 बीटा के साथ एक ज्ञात समस्या है, इसलिए यह बीटा चीज़ हो सकती है और एक्सकोड अतिरिक्त वर्बोज़ हो रहा है यह 8.2.1 के साथ अच्छी तरह से काम करता है, इसलिए मैं चेतावनी से बचने या 8.3 बीटा पर चेतावनियों को अनदेखा करने के लिए अस्थायी रूप से इसका उपयोग करने का सुझाव देता हूं यदि यह आपके ऐप को प्रभावित नहीं करता है।





warnings