ubuntu यार्न स्थापित कमांड त्रुटि ऐसी कोई फाइल या निर्देशिका नहीं:




ubuntu-14.04 sylius (6)

मैं सिलिअस बंडल स्थापित कर रहा हूं और सिलिअस स्थापित करते समय मुझे यार्न स्थापित चलाने की आवश्यकता है, जबकि मैं कमांड चलाता हूं

yarn install

मुझे त्रुटि मिली:

त्रुटि: [त्रुटि २] ऐसी कोई फ़ाइल या निर्देशिका नहीं: 'स्थापित करें'


मेरे पास उबंटू 18.04 पर एक ही मुद्दा था। यह मेरे लिए काम कर रहा था:

मैंने cmdtest और yarn हटा दिया

sudo apt remove cmdtest

sudo apt remove yarn

Npm का उपयोग करके विश्व स्तर पर यार्न स्थापित करें

sudo npm install -g yarn

मेरे पास उबंटू 17.04 पर एक ही मुद्दा था।

इस समाधान ने मेरे लिए काम किया:

~$ sudo apt remove cmdtest
~$ sudo apt remove yarn
~$ curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
~$ echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
~$ sudo apt-get update  
~$ sudo apt-get install yarn

फिर

~$ yarn install

परिणाम:

yarn install v1.3.2
warning You are using Node "6.0.0" which is not supported and may encounter bugs or unexpected behavior. Yarn supports the following semver range: "^4.8.0 || ^5.7.0 || ^6.2.2 || >=8.0.0"
info No lockfile found.
[1/4] Resolving packages...
[2/4] Fetching packages...
[3/4] Linking dependencies...
[4/4] Building fresh packages...

info Lockfile not saved, no dependencies.
Done in 0.20s.

आशा है कि यह आपकी मदद करेगा।


इसके अलावा यह मुद्दा (विंडोज़) था, फिक्स सभी टर्मिनल उदाहरणों का एक पूर्ण समापन था, फिर पुन: प्रयास करें।


sudo npm install -g yarnpkg
npm WARN deprecated [email protected]: Please use the `yarn` package instead of `yarnpkg`

इसलिए यह मेरे लिए काम करता है

sudo npm install -g yarn

यह मेरे लिए काम किया

sudo yarn install

Ubuntu 16.04 के लिए यार्न स्थापित करना (यह सुनिश्चित नहीं है कि यह 14.04 जैसा ही होगा क्योंकि यह 17.04 के जैपी के उत्तर से थोड़ा अलग है)

curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
curl -sL https://deb.nodesource.com/setup_9.x | sudo -E bash -
apt-get update
apt-get install nodejs
apt-get install yarn

फिर जहाँ से भी आपने अपना सिलिसियस प्रोजेक्ट स्थापित किया है (/ var / www / mysite)

yarn install
yarn run gulp




yarnpkg