angular - कोणीय 4.x को 5 कोणीय में ले जाना




angular5 (2)

आपको सभी कोणीय उपलब्ध कराए गए पैकेजों को उनके नवीनतम संस्करणों में अपडेट करने की आवश्यकता है:

npm install [email protected] --save-dev

npm install @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] @angular/[email protected] --save

यह सभी आवश्यक करना चाहिए। इसके अलावा आप अपने कोणीय क्ली को भी अपडेट कर सकते हैं कि कोणीय 5 के साथ जहाज मानक संस्करण के रूप में निम्नानुसार हैं:

npm uninstall -g @angular/cli
npm cache clean
npm install -g @angular/[email protected]

एंगुलर टीम की आधिकारिक ब्लॉगपोस्ट यहाँ है: https://angular-update-guide.firebaseapp.com/ । यह अपडेट गाइड आपको किसी भी संस्करण से नवीनतम एक पर माइग्रेट करने में मदद करेगा।

इस सवाल का पहले से ही यहाँ एक जवाब है:

मैंने निम्नलिखित ब्लॉग और प्रलेखन पढ़ा है

और 4.x से 5 तक कैसे जाएं, इसके बारे में कोई स्पष्ट जानकारी नहीं।

निम्न आदेशों की कोशिश की

मेरे लिए कुछ भी ठीक नहीं रहा। कृपया सहायता कीजिए


इस वेबसाइट ने मेरे लिए इसे बहुत आसान बना दिया। अपने संस्करण में रखो तुम से उन्नयन कर रहे हैं, और जो आप के लिए उन्नयन कर रहे हैं। मेरा ऐप सरल है, इसलिए यह आपके ऐप की जटिलता पर निर्भर हो सकता है।





angular5