AngularFirestore और firebase का उपयोग करते हुए “ERROR TypeError: Object(…) एक फ़ंक्शन नहीं है”




angularfire2 (6)

मैं अपने ऐप में फायरबेस और एंगुलरफायर 2 का उपयोग करना चाहता हूं, सबसे पहले, मैंने उन्हें स्थापित किया, और घोषणाओं के लिए:

पर्यावरण में

export const environment = {
    production: false,
    firebase: {
    apiKey: 'sfsdfdsff',
    authDomain: 'sfsdfdf',
    databaseURL: 'https://ng-sfsdfsf.firebaseio.com',
    projectId: 'ng-fitnesssfsdfdsf',
    storageBucket: 'ng-fsdfsdfsfdecff5.appspot.com',
   messagingSenderId: '21331323'
   }
  };

app.module.ts में, आयात:

AngularFireModule.initializeApp(environment.firebase),
AngularFirestoreModule

उस घटक में जहां मेरा डेटा प्राप्त करना चाहते हैं:

import { AngularFirestore } from 'angularfire2/firestore';

इस क्षण तक मेरे पास कोई त्रुटि नहीं है, लेकिन जब मैं इसका उपयोग करने के लिए कंस्ट्रक्टर में अपना चर घोषित करना चाहता हूं:

constructor(private trainingService: TrainingService, private 
db:AngularFirestore) { }

मेरे पास एक त्रुटि है:

ERROR TypeError: Object(...) is not a function
at eval (firestore.js:28)
at ZoneDelegate.invoke (zone.js:388)
at Zone.run (zone.js:138)

मेरे पैकेज में। Json:

"angularfire2": "^5.0.0-rc.8.0",
"core-js": "^2.4.1",
"firebase": "^5.0.2",

और मुझे नहीं पता क्यों?

आपकी सहायता के लिए धन्यवाद


AngularFire मेंटेनर के रूप में, हमारे पास 5.0 जीए की ओर मार्च करते हुए कई ब्रेकिंग परिवर्तन हुए हैं। एंगुलर 6 का समर्थन करने के लिए, एंगुलरफायर के हालिया रिलीज को आरएक्सजे 6 की आवश्यकता होती है। हां, जबकि पुराने संस्करण को डाउनग्रेड या पिन करना त्वरित और गंदे फिक्स के लिए काम करेगा, मैं सुझाव नहीं दूंगा कि यह आपको पुस्तकालयों में सुधार से बाहर कर देगा। भविष्य।

अगर आप अभी तक उन्नत नहीं है निर्भरता है, तो मैं संस्करण 6 के लिए rxj6 और rxjs-compat सहित rxj6 को अपग्रेड करने की सलाह दूंगा:

npm i [email protected]^6.0 rxjs-compat

किसी भी ब्रेकिंग परिवर्तन के बारे में महत्वपूर्ण जानकारी के लिए कोणीय गोलाबारी में नजर रखें; एक बार जब हम GA को हिट करते हैं तो हम सेवर का पालन करेंगे।

और यहाँ संदर्भ के लिए RXJS 5 => 6 माइग्रेशन गाइड है


मुझे भी यही त्रुटि मिली। जैसे ही मैंने sudo npm update rxjs npm अपडेट rxjs के साथ rxjs को sudo npm update rxjs । और फिर sudo npm i [email protected] rxjs-compat । कमजोरियों को ठीक करने और फिर ng build चलाने के बाद ng serve । इससे मेरी त्रुटि ठीक हो गई। (macOS पर)


मैंने पहली बार फ़ायरबेस और कोणीयफायर 2 की स्थापना रद्द की:

  • npm uninstall firebase
  • npm uninstall angularfire2

और फिर से फिर से स्थापित किया गया:

वास्तव में स्थापित संस्करणों में ^ का उपयोग करना [email protected] है, इसलिए मैंने अभी उस हिस्से को हटा दिया है।



"angularfire2": 5.0.0-rc.9 स्थापित करते समय मेरे पास एक ही त्रुटि है "angularfire2": 5.0.0-rc.9

त्रुटि आई जब मैं 5.0.0-rc.6 लिए रोलबैक।

npm install [email protected]
npm install [email protected]







angularfire2