apache का - मैं मैक ओएस एक्स पर अपाचे चींटी कैसे स्थापित कर सकता हूं?




भोजन in (8)

मैंने अपने मैक पर अपाचे चींटी स्थापित करने की कोशिश की और मैंने अगले चरणों का पालन किया:

  1. मैंने अपने डाउनलोड फ़ोल्डर में apache-ant-1.8.1-bin.tar.gz डाउनलोड किया।
  2. मैंने फ़ाइल को /usr/local/ इस आदेश का उपयोग करके स्थानांतरित किया: mv apache-ant-1.8.1-bin.tar.gz /usr/local/ sudo sh और mv apache-ant-1.8.1-bin.tar.gz /usr/local/

अब मैं cd /usr/local/ का उपयोग करना चाहता हूं लेकिन यह काम नहीं कर रहा है, मैं वापस "ऐसी कोई फ़ाइल या निर्देशिका नहीं" प्राप्त करता हूं।

तब मैंने cd /usr/ और ls कमांड का इस्तेमाल किया और ऐसा लगता है कि स्थानीय फ़ोल्डर वहां है। अगर मैं इसे एक्सेस करने का प्रयास करता हूं तो मुझे एक ही त्रुटि मिलती है।

चूंकि मैंने पहले से ही sudo su उपयोग किया है, इसलिए मैं इसका उपयोग क्यों नहीं कर सकता? कोई विचार?


Answers

MacOSX Mac.9X 10.9 में आपके लिए चींटी इंस्टॉल करेगा। महज प्रयोग करें

$ sudo port install apache-ant

और यह स्थापित होगा।


यदि आप मैकपोर्ट के बजाय होमब्री उपयोगकर्ता हैं, तो होमब्री में चींटी नुस्खा है।

brew install ant


ब्रेंट का उपयोग एएनटी और अन्य जरूरतों को स्थापित करने का हमेशा अच्छा तरीका है। टर्मिनल पर नीचे दिए गए कमांड को स्थापित करने के लिए।

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

ब्रू स्थापना के बाद, टाइप करें

brew install ant

यह आपके सिस्टम पर चींटी स्थापित करेगा। इसके अलावा आपको पथ स्थापित करने की चिंता करने की आवश्यकता नहीं होगी।

इसके अलावा मैंने उसी पर दस्तावेज किया है - मैक ओएस पर एएनटी कैसे स्थापित करें?


5 मिनट में अपने मैक पर चींटी चलाने के लिए, इन चरणों का पालन करें।

अपना टर्मिनल खोलें।

इन आदेशों को क्रम में करें:

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

brew install ant

यदि आपके पास जावा अभी तक स्थापित नहीं है, तो आपको निम्न त्रुटि मिल जाएगी: "त्रुटि: एक असंतुष्ट आवश्यकता इस बिल्ड में विफल रही।" इस कमांड को अगला चलाएं: इसे ठीक करने के लिए brew cask install java करें।

स्थापना फिर से शुरू हो जाएगी।

इस आदेश को चलाकर अपने संस्करण की जांच करें:

ant -version

और आप जाने के लिए तैयार हैं!


मैक पर 1.8.2 से 1.9.1 तक अपडेट किया गया मेरा एंट वर्जन एकमात्र तरीका यहां निर्देशों का पालन करके था

http://wiki.eclipse.org/Ant/User_Guide


यदि आपके पास MacPorts इंस्टॉल हैं ( https://www.macports.org/ ), ऐसा करें:

sudo port install apache-ant

चींटी पहले से ही मैक ओएस एक्स के कुछ पुराने संस्करणों पर स्थापित है, इसलिए इसे स्थापित करने का प्रयास करने से पहले इसे स्थापित करने के लिए आपको ant -version चलाया जाना चाहिए।

यदि यह पहले से स्थापित नहीं है, तो आपका सबसे अच्छा शर्त Homebrew ( brew install ant ) या MacPorts ( sudo port install apache-ant ) sudo port install apache-ant , और अपाचे एंटी इंस्टॉल करने के लिए उन उपकरणों का उपयोग करें।

वैकल्पिक रूप से, हालांकि मैं इसके बजाय होमब्री या मैकपॉर्ट्स का उपयोग करने की सलाह देता हूं, आप मैन्युअल रूप से अपाचे एंटी इंस्टॉल कर सकते हैं। ऐसा करने के लिए, आपको यह करना होगा:

  1. .tar.gz फ़ाइल को डिकंप्रेस करें।
  2. वैकल्पिक रूप से इसे कहीं भी रखा।
  3. अपने पथ में "बिन" उपनिर्देशिका रखो।

apache-ant-1.8.1-bin.tar.gz (वास्तविक संस्करण के साथ 1.8.1 को प्रतिस्थापित करें) मानते हुए आपको आवश्यक आदेशों को अभी भी आपकी डाउनलोड निर्देशिका में रखा गया था, निम्नलिखित (व्याख्यात्मक टिप्पणियां शामिल हैं):

cd ~/Downloads # Let's get into your downloads folder.
tar -xvzf apache-ant-1.8.1-bin.tar.gz # Extract the folder
sudo mkdir -p /usr/local # Ensure that /usr/local exists
sudo cp -rf apache-ant-1.8.1-bin /usr/local/apache-ant # Copy it into /usr/local
# Add the new version of Ant to current terminal session
export PATH=/usr/local/apache-ant/bin:"$PATH"
# Add the new version of Ant to future terminal sessions
echo 'export PATH=/usr/local/apache-ant/bin:"$PATH"' >> ~/.profile
# Verify new version of ant
ant -version

आप इस समस्या को अपने .bash_profile में ठीक करने के लिए आदेश को उपनाम कर सकते हैं और हर बार इसे सामना करते समय इसे चला सकते हैं:

फ़ाइल ~/.bash_profile के अंत में, जोड़ें:

alias fix_brew='sudo chown -R $USER /usr/local/'

और अब आपके टर्मिनल के अंदर आप चला सकते हैं:

$ fix_brew




apache ant macos