arm - Sourcery G++(एआरएम के लिए क्रॉस-कंपाइलर) स्थापना विफलता




cross-compiling codesourcery (2)

मैं निम्नलिखित लिंक से उबंटू 10.04 एलटीएस पर एआरएम के लिए Sourcery G ++ क्रॉस-कंपाइलर स्थापित करने की कोशिश कर रहा था-> http://www.codesourcery.com/sgpp/lite/arm/portal/release644 मैं ग्राफिकल इंटरफ़ेस का उपयोग नहीं किया क्योंकि मैं java.awt त्रुटि मिली स्थापना के कंसोल मोड का उपयोग करते समय, मैंने प्रोग्राम द्वारा पूछे गए सभी विवरण प्रदान किए। (स्थापना के डिफ़ॉल्ट स्थान को बदल दिया गया)

स्थापना में कुछ समय, मुझे यह त्रुटि मिली:

फ़ाइल लिंक बनाने में असमर्थ

एक आंतरिक कार्यक्रम चलाने के दौरान एक त्रुटि हुई कृपया टूलकेन को "/ home // cross_compiler" से निकालें। EXITCODE = -1

मुझे यकीन नहीं है कि इसका कारण क्या है मैं इस प्रक्रिया को एक रूट उपयोगकर्ता के रूप में फिर से लाल कर दिया और मुझे अभी भी एक ही त्रुटि मिली। मैं इसे 64 बिट मशीन पर स्थापित करने की कोशिश कर रहा हूं।


Sourcery CodeBench को स्थापित करने के लिए आपके पास 32-बिट संगतता पुस्तकालयों को स्थापित करना होगा।

अकसर किये गए सवाल से: "x86 64-बिट लिनक्स होस्ट सिस्टम पर सॉर्केरी कोडबेंच को स्थापित करने और चलाने के लिए मुझे क्या करने की आवश्यकता है?" https://sourcery.mentor.com/sgpp/lite/arm/portal/kbentry62

पूर्ण सामान्य प्रश्न यहाँ: https://sourcery.mentor.com/sgpp/lite/arm/portal/[email protected]=faq&target_arch=arm

एआरएम लाइट संस्करण उपकरण की अपनी मेलिंग सूची है, जहां आप ऐसे प्रश्न पूछ सकते हैं। Sourcerytools.com पर जाएं और एआरएम लाइट संस्करण प्रश्नों के लिए "आर्म-ग्नु" मेलिंग सूची का उपयोग करें।

चीयर्स!


मुझे लगता है कि आपकी सिस्टम आवश्यकताएं जांचना महत्वपूर्ण है।

संभावना है कि आप उबंटू की 64 बिट बिल्ड चल रहे हैं

शोरसी जी ++ 32 बिट होस्ट पुस्तकालयों की आवश्यकता है सुनिश्चित करें कि वे स्थापित हैं

मेरे दिमाग में, वीएम में 32 बिट इंस्टॉलेशन को चलाने में आसान हो सकता है

यदि यह संभव नहीं है, तो आपके स्थापना प्रयास निर्देशिका की 'स्थापना रद्द' निर्देशिका में इंस्टॉलेशन लॉग हैं। इससे आपको समस्या का निवारण करने में मदद मिल सकती है