coffeescript - मैं कॉफ़िशस्क्रिप्ट इंटरएक्टिव मोड(REPL) में बहु-कोड नहीं लिख सकता




multiline interactive (2)

आप Ctrl + V के साथ मल्टीलाइन मोड में भी स्विच कर सकते हैं।

जब मैंने कॉफ़ीसेस्क्रिप्ट इंटरैक्टिव मोड में मल्टीलाइन टाइप किया, तो त्रुटि उत्पन्न हुई।

निर्वासन के लिए, मैं निम्नलिखित कोड का प्रयास करना चाहता हूं।

kids =
  brother:
    name: "Max"
    age:  11
  sister:
    name: "Ida"
    age:  9

यह त्रुटि प्रदर्शित की गई थी।

coffee> kids = 
Error: In repl, Parse error on line 1: Unexpected 'TERMINATOR'
  at Object.parseError (/usr/lib/coffeescript/parser.js:463:11)
  at Object.parse (/usr/lib/coffeescript/parser.js:533:22)
  at /usr/lib/coffeescript/coffee-script.js:26:22
  at Object.eval (/usr/lib/coffeescript/coffee-script.js:64:17)
  at Interface.<anonymous> (/usr/lib/coffeescript/repl.js:18:26)
  at Interface.emit (events:27:15)
  at Interface._ttyWrite (readline:309:12)
  at Interface.write (readline:147:30)
  at Stream.<anonymous> (/usr/lib/coffeescript/repl.js:35:17)
  at Stream.emit (events:27:15)

मैंने एक नई पंक्ति के रूप में '\' का उपयोग करने की कोशिश की, लेकिन वही त्रुटि प्रदर्शित की गई।

coffee> kids = \
Error: In repl, Parse error on line 1: Unexpected '\'
  at Object.parseError (/usr/lib/coffeescript/parser.js:463:11)
  at Object.parse (/usr/lib/coffeescript/parser.js:533:22)
  at /usr/lib/coffeescript/coffee-script.js:26:22
  at Object.eval (/usr/lib/coffeescript/coffee-script.js:64:17)
  at Interface.<anonymous> (/usr/lib/coffeescript/repl.js:18:26)
  at Interface.emit (events:27:15)
  at Interface._ttyWrite (readline:309:12)
  at Interface.write (readline:147:30)
  at Stream.<anonymous> (/usr/lib/coffeescript/repl.js:35:17)
  at Stream.emit (events:27:15)

मैं मल्टीलाइन का उपयोग नहीं कर सकता, इसलिए मैं इंडेंटेशन का उपयोग नहीं कर सकता।

मुझे क्या करना चाहिए?

मेरा वातावरण निम्नलिखित है

  • OS: उबंटू 10.04 ल्यूसिड

  • coffeescript संस्करण 1.0.0 मैंने PPA और apt-get कमांड के साथ coffeescript स्थापित किया है।

    इस url को देखें। https://launchpad.net/~gezakovacs/+archive/coffeescript


बैकस्लैश मेरी कॉफी 1.2.1 के साथ ठीक काम करता है ... अपग्रेड करने की कोशिश :)





read-eval-print-loop