python - पाइप का उपयोग कर SciPy और NumPy स्थापित करना




pip apt (6)

चूंकि यम के साथ स्थापित करने के पिछले निर्देश यहां टूटे हुए हैं जैसे फेडोरा जैसे कुछ स्थापित करने के लिए अद्यतन निर्देश हैं। मैंने इसका परीक्षण "अमेज़ॅन लिनक्स एएमआई 2016.03" पर किया है

sudo yum install atlas-devel lapack-devel blas-devel libgfortran
pip install scipy

मैं एक पैकेज में आवश्यक पुस्तकालय बनाने की कोशिश कर रहा हूं जिसे मैं वितरित कर रहा हूं। इसके लिए SciPy और NumPy लाइब्रेरी दोनों की आवश्यकता होती है। विकास करते समय, मैंने दोनों का उपयोग किया

apt-get install scipy

जिसने SciPy 0.9.0 और NumPy 1.5.1 स्थापित किया, और यह ठीक काम किया।

मैं अपने स्वयं के पैकेज के setup.py में निर्भरताओं को निर्दिष्ट करने में सक्षम होने के लिए, pip install का उपयोग करके ऐसा करना चाहता हूं।

समस्या यह है कि, जब मैं कोशिश करता हूं:

pip install 'numpy==1.5.1'

यह बढ़िया काम करता है।

परन्तु फिर

pip install 'scipy==0.9.0'

साथ, बुरी तरह विफल रहता है

raise self.notfounderror(self.notfounderror.__doc__)

numpy.distutils.system_info.BlasNotFoundError:

Blas (http://www.netlib.org/blas/) libraries not found.

Directories to search for the libraries can be specified in the

numpy/distutils/site.cfg file (section [blas]) or by setting

the BLAS environment variable.

मैं इसे काम पर कैसे लगाऊं?


मेरे मामले में, पीपी को अपग्रेड करने से चाल चल रही थी। इसके अलावा, मैंने -यू पैरामीटर के साथ scipy स्थापित किया है (सभी उपलब्ध संकुल को अंतिम उपलब्ध संस्करण में अपग्रेड करें)


मैं एक परियोजना पर काम कर रहा था जो numpy और scipy पर निर्भर था। फेडोथन 3.4 के लिए एक पायथन वर्चुअल वातावरण का उपयोग करके फेडोरा 23 की एक साफ स्थापना में (पायथन 2.7 के लिए भी काम किया), और मेरे setup.py में (निम्न ( setup() विधि) में निम्नलिखित के साथ)

setup_requires=[
    'numpy',
],
install_requires=[
    'numpy',
    'scipy',
],

मैंने पाया कि मुझे pip install -e . करने के लिए निम्नलिखित चलाना पड़ा था pip install -e . काम करने के लिए:

pip install --upgrade pip

तथा

sudo dnf install atlas-devel gcc-{c++,gfortran} subversion redhat-rpm-config

redhat-rpm-config नियमित cc1 विपरीत redhat-hardened-cc1 scipy के उपयोग के लिए है


यदि आप उबंटू का उपयोग कर रहे हैं तो आपको libblas और liblapack dev संकुल की आवश्यकता है।

aptitude install libblas-dev liblapack-dev
pip install scipy

यह ऑपरेटिंग सिस्टम क्या है? जवाब शामिल ओएस पर निर्भर हो सकता है। हालांकि, ऐसा लगता है कि आपको इस BLAS पुस्तकालय को ढूंढने और इसे स्थापित करने की आवश्यकता है। यह पीआईपी में प्रतीत नहीं होता है (आपको इसे हाथ से करना होगा), लेकिन अगर आप इसे इंस्टॉल करते हैं, तो आपको अपने SciPy इंस्टॉल को प्रगति करने देना चाहिए।


विंडोज़ पर , python 3.5 का उपयोग करके, मैं conda नहीं pip का उपयोग कर scipy स्थापित करने में कामयाब रहे:

conda install scipy




apt