Azure.NET 4.5 समर्थन




.net-4.5 (6)

यदि आपको उपयोगकर्ता के लिए नेट पर आवश्यकता है, तो कृपया Azure UserVoice साइट पर जाएं और इसके लिए वोट दें: http://www.mygreatwindowsazireidea.com/forums/34192-windows-zure-feature-voting/suggestions/2598170-iis8 -और-एएसपी निवल 4-5-समर्थन-इन-नीला मंच

ठीक है, मुझे इस ऑनलाइन पर एक निश्चित जवाब नहीं मिल रहा है, इसलिए मैंने सोचा कि मैं इस समुदाय से पूछूंगा। .NET 4.5 पिछले हफ्ते आरटीएम चला गया है और हमारे उत्पादों को इसका उपयोग करने के लिए उन्नयन करने के लिए देख रहे थे। इस छलांग को बनाने से पहले, मुझे सबसे पहले यह जांचना होगा कि क्या यह हमारे उत्पाद (एएसपी.नेट एमवीसी सामान) के साथ किसी एज़्यूर की तैनाती पर असर डालेगा। अभी तक इसकी वेब और कार्यकर्ता भूमिकाओं में एज़्यूर प्लेटफॉर्म समर्थन .NET 4.5 का नवीनतम उत्पादन संस्करण क्या है? मुझे पता है कि फ्रेमवर्क के आर.सी. वीएम / रोल के दौरान स्टार्टअप पावर शेल स्क्रिप्ट का प्रयोग करके स्थापित किया जा सकता है, लेकिन मुझे इस आवेदन पर यह बोझ नहीं चाहिए, मैं सिर्फ इसके सुरक्षित होने के बारे में जानना चाहता हूं एनएटी 4.5 और एमवीसी 4 आदि के साथ रहें ... Azure के वर्तमान स्थिति में?


विंडोज़ एज़ूर क्लाउड सर्विसेज (पाअस) के लिए विंडोज़ज़्यूर एसडीके केवल। 4.0 का समर्थन करता है। 4.5 के रूप में सिर्फ आरटीएम है, इसे विंडोज़ एज़ूर एसडीके के लिए। 4.5 का समर्थन करने में कुछ समय लगेगा, हालांकि कहीं भी समयरेखा चर्चा नहीं हुई है और अगर इस संबंध में कोई जानकारी होगी, तो यह विंडोज़ ऐज़ोर वेबसाइट पर संचार होगा।

यदि आपके आवेदन में। 4.5 होना चाहिए, तो आप Windows Azure Virtual Machine को Windows OS के साथ प्रयोग कर सकते हैं और .NET 4.5 इंस्टॉल कर सकते हैं और आप चुनते समय MVC4 एप्लिकेशन को बना सकते हैं / चला सकते हैं।


माइक्रोसॉफ्ट ने आज ही घोषणा की है कि एनएटी 4.5 का समर्थन Azure के लिए बहुत जल्द आ रहा है और मौजूदा क्षुधा के लिए अपग्रेड गाइड भेजता है।

चिंता का विषय है कि .NET 4.0 में से कुछ परिवर्तन और बग फिक्स जो कि .NET 4.5 में लुढ़क गए हैं, वे मौजूदा वेब अनुप्रयोगों पर प्रतिकूल प्रभाव डाल सकते हैं। ई-मेल ने निरूपित किया कि अपग्रेड इस सप्ताह के अंत में रोलिंग कर रहा था और लोगों को इन्हें Visual Studio 2012 में .NET 4.5 में अपग्रेड करने के लिए कहा।


स्कॉट गुथरी के अनुसार, 25 अक्टूबर तक, .NET 4.5 विंडोज़ Azure वेब साइट्स पर समर्थित है I

विंडोज़ एज़ूर क्लाउड सर्विसेज (वेब ​​और वर्कर भूमिका) को "अगले कुछ दिनों में" (संभवतः अक्टूबर 2012 के अंत तक) का समर्थन किया जाएगा।


एज़्यूर एसडीके v1.8 (अक्टूबर 2012) डाउनलोड के लिए बाहर है: http://www.microsoft.com/en-us/download/details.aspx?id=35448

समर्थन करता है: .नेट 4.5, विंडोज सर्वर 2012 और आईआईएस 8.0: http://msdn.microsoft.com/en-us/library/windowsazure/ff683673.aspx#BK_October2012

Windows Server 2012 का उपयोग करने के लिए जो .NET 4.5 का समर्थन करता है, osFamily = "2" को ओज़फैमिली = "3" में अपनी नीला भूमिका .cscfg फ़ाइल में बदलें।

संपादित करें: मैंने पिछली रात विंडोज सर्वर 2012 / .NET 4.5 पर मेरी दो साइटों को अपडेट किया था और वे एक विजेता की तरह काम करते हैं तो, यह सभी आरटीएम / स्थिर कोड है, जो सिर्फ घोषणा के लिए इंतजार कर रहा है (शायद 2012 का निर्माण?)। यदि आप Windows Server 2012 का उपयोग कर रहे हैं, तो आपको .NET 3.5-.NET 3.5 ऐप / मॉड्यूल के साथ पिछड़े संगतता के लिए .NET 3.5 सुविधाएँ सक्षम करने की आवश्यकता है।

संपादित करें 2: बुलड 2012 सम्मेलन में कल 0 का समर्थन किया गया था। Http://channel9.msdn.com


अक्तूबर 2012 अपडेट्स (पेज पर वेबपीआई लिंक के माध्यम से) को डाउनलोड करने और इंस्टॉल करने के बाद भी, जो ऊपर सूचीबद्ध @ बर्ट पर है, आपको अब भी अपने एज़्योर प्रोजेक्ट को हटाने और उसे रीमेक करना होगा - यह केवल एक ही चीज़ थी जिसे "विंडोज़ एज़ूर क्लाउड सेवा प्रोजेक्ट्स वर्तमान में एनएटी फ्रेमवर्क संस्करण 3.5 और 4 पर चलने वाली भूमिकाओं का समर्थन करते हैं। कृपया परियोजना " मेरे लिए त्रुटि के लिए परियोजना सेटिंग्स में लक्ष्य फ्रेमवर्क संपत्ति सेट करें

यहां तक ​​कि जब मैंने ओएसफ़ैमिली को "3" में बदल दिया, तब तक जब तक मैं ऐज़्योर प्रॉजे को दूर नहीं कर दिया।

मैं इसे ठीक करने की कोशिश नहीं कर पाया, लेकिन मुझे आश्चर्य है कि स्कीमा विर्सन को schemaVersion="2012-10.1.8" लिए .cscfg में सेट करना ने इसे उड़ा देने की मेरी जरूरत को नकार कर दिया होगा।





.net-4.5