visual-studio-2010 - net fra framework 4.5 download




विजुअल स्टूडियो 2010 के माध्यम से.NET Framework 4.5 को लक्षित करना (4)

एक और खोज से। मेरे लिए काम किया!

"आप विजुअल स्टूडियो 2010 का उपयोग कर सकते हैं और यह इसका समर्थन करता है, बशर्ते आपका ओएस .NET 4.5 का समर्थन करता हो।

संदर्भ जोड़ने के लिए अपने समाधान पर राइट क्लिक करें (जैसा कि आप करते हैं)। जब संवाद बॉक्स दिखाता है, ब्राउज़ करें का चयन करें, फिर निम्न फ़ोल्डर पर नेविगेट करें:

सी: \ प्रोग्राम फ़ाइलें (x86) \ संदर्भ असेंबली \ Microsoft \ Framework \ .Net Framework \ 4.5

आप इसे वहां पाएंगे। "

आज मैंने अपनी मशीन पर .NET Framework 4.5 को विजुअल स्टूडियो 2010 से इसका उपयोग करने में सक्षम होने की उम्मीद की है, क्योंकि यह केवल एक मामूली अपडेट है जो विजुअल स्टूडियो 2010 के लिए समस्याएं उत्पन्न नहीं कर सकता है। दुर्भाग्य से मैं कुछ 4.0 को मैन्युअल रूप से हटा नहीं रहा हूं और इसी 4.5 असेंबली को जोड़ने के परिणामस्वरूप मूल 4.0 असेंबली अभी भी परियोजना में संदर्भित की जा रही हैं।

क्या विजुअल स्टूडियो 2010 से संस्करण 4.5 को लक्षित करना संभव है और यदि हां, तो कैसे? मैं वास्तव में रिबन का उपयोग करना चाहूंगा ...


एफवाईआई, यदि आप वीएस -2010 में इंस्टॉलर पैकेज बनाना चाहते हैं, दुर्भाग्यवश यह केवल .NET 4 को लक्षित करता है। इसके आसपास काम करने के लिए, आपको लॉन्च स्थिति के रूप में नेट 4.5 जोड़ना होगा।

इंस्टॉलर की लॉन्च स्थितियों में निम्न जोड़ें (राइट क्लिक, देखें, लॉन्च स्थितियां)।

"खोज लक्ष्य मशीन" में, राइट क्लिक करें और "रजिस्ट्री खोज जोड़ें" का चयन करें।

Property: REGISTRYVALUE1
RegKey: Software\Microsoft\NET Framework Setup\NDP\v4\Full
Root: vsdrrHKLM
Value: Release

नई "लॉन्च हालत" जोड़ें:

Condition: REGISTRYVALUE1>="#378389"
InstallUrl: http://www.microsoft.com/en-gb/download/details.aspx?id=30653
Message: Setup requires .NET Framework 4.5 to be installed.

कहा पे:

37838 9 = .NET फ्रेमवर्क 4.5

378675 = .NET Framework 4.5.1 विंडोज 8.1 के साथ स्थापित है

378758 = .NET Framework 4.5.1 विंडोज 8, विंडोज 7 एसपी 1, या विंडोज विस्टा एसपी 2 पर स्थापित है

37 9 8 9 3 = .NET फ्रेमवर्क 4.5.2

लॉन्च हालत संदर्भ: http://msdn.microsoft.com/en-us/library/vstudio/xxyh2e6a(v=vs.100).aspx


मैं वीएस -2010 / डीएनएफडब्ल्यू 4.5 एकीकरण के साथ संघर्ष कर रहा हूं और अंत में यह काम कर रहा है। वीएस 2008 में शुरू होने से, असेंबली का एक कैश पेश किया गया था जिसका उपयोग विजुअल स्टूडियो द्वारा किया जाता है जिसे "संदर्भित असेंबली" कहा जाता है। वीएस 2010 के लिए यह फ़ाइल कैश \ संदर्भ असेंबली \ Microsoft \ Framework.NetFramework \ v4.0 पर स्थित है। दृश्य स्टूडियो फ्रेमवर्क स्थापना निर्देशिका के बजाय इस स्थान से फ्रेमवर्क असेंबली लोड करता है। जब माइक्रोसॉफ्ट का कहना है कि वीएस 2010 डीएनएफडब्लू 4.5 का समर्थन नहीं करता है तो उनका मतलब यह है कि डीएनएफडब्लू 4.5 स्थापित होने पर यह निर्देशिका अद्यतन नहीं होती है। एक बार जब आप अपडेट की गई डीएनएफडब्लू 4.5 फाइलों के साथ इस स्थान में फ़ाइलों को प्रतिस्थापित कर लेंगे, तो आप पाएंगे कि वीएस 2010 खुशी से डीएनएफडब्लू 4.5 के साथ काम करेगा।


विजुअल स्टूडियो 2010 से पहले विजुअल स्टूडियो का प्रत्येक संस्करण एक विशिष्ट .NET ढांचे से जुड़ा हुआ है। (वीएस -2008 .NET 3.5 है, वीएस2005 .NET 2.0 है, वीएस2003 .NET1.1 है) विजुअल स्टूडियो 2010 और इससे पहले पूर्व ढांचे के संस्करणों को लक्षित करने की अनुमति है लेकिन भविष्य में रिलीज के लिए इसका उपयोग नहीं किया जा सकता है। .NET 4.5 का उपयोग करने के लिए आपको विजुअल स्टूडियो 2012 का उपयोग करना होगा।





.net-4.5