[चेतावनी] वर्तमान कार्य निर्देशिका(सी: \ xampp \ htdocs \ sencha फ़ोल्डर) एक मान्यता प्राप्त Sencha SDK या अनुप्रयोग फ़ोल्डर नहीं है।




command extjs (5)

बस निम्नलिखित चरणों का पालन करें: -

  1. नवीनतम सेनेका एसडीके डाउनलोड करें http://www.sencha.com/products/touch/download/
  2. नवीनतम सेचा कमांड लाइन http://www.sencha.com/products/sencha-cmd/download डाउनलोड करें
  3. Windows में सेचा कमांड लाइन डिफ़ॉल्ट स्थान स्थापित करें C: \ Users \ XXX \ bin
  4. सीएमडी स्थापना के बाद स्टेप 1 में एसडीके फ़ोल्डर स्थापित / निकालें
  5. निम्न कमांड चलाएं (मैं इस आदेश को विंडोज़ पर जीआईटी बैश का उपयोग कर रहा हूँ)

    /c/Users/SMAK/bin/Sencha/Cmd/3.0.0.250/sencha ऐप उत्पन्न करते हैं MyApp ../MyApp

नोट: - हमें सेंचा एसडीके और सीएमडी दोनों की जरूरत है और आपको एसडीके फ़ोल्डर से कमांड चलाने की जरूरत है

मैं सेन्का में नया हूँ लेकिन स्थापना के बाद .. यह वास्तव में एक सिरदर्द बन रहा है ..

मैं 'इस समस्या को हल करने के लिए कैसे पता नहीं है .. मैं डाउनलोड -

  • sencha-touch-2.1.0- वाणिज्यिक - (इसकी एसडीके मुझे लगता है)
  • SenchaSDKTools-2.0.0-beta3-windows (ये एसडीके के लिए उपकरण हैं)
  • एक्सएम्पपी (वेब ​​सेवाओं के लिए)

  • मैं xampp स्थापित

  • xampp के तहत htdocs फ़ोल्डर में sencha स्पर्श निकाल दिया
  • स्थापित senchSDKTools

    और सीएमडी से कमांड लागू करना शुरू कर दिया

  • मैंने सिंचन टाइप किया और दबाया ...
  • लेकिन मुझे निम्नलिखित त्रुटि मिलती है

-

C:\xampp\htdocs\sencha-touch-2.1.0-commercial>sencha
[WARN] The current working directory (C:\xampp\htdocs\sencha-touch-2.1.0-commercia
l) is not a recognized Sencha SDK or application folder. Running in backwards comp
atible mode.

    Sencha Command v2.0.0 Beta 3
Copyright (c) 2012 Sencha Inc.
usage: sencha COMMAND [ARGS]

The available commands are:
   build                        build a JSB project
   create bootstrapdata         generate boostrap data
   create jsb                   generate a minimal JSB project for an app
   create locale                        generate a template locale file from sourc
e
   create manifest              generate classes manifest
   package                      package your Touch web app into a native bundle
   slice theme                  slice a custom theme's images for IE

See 'sencha help COMMAND' for more information on a specific command.

C:\xampp\htdocs\sencha-touch-2.1.0-commercial>

-मैंने कई वेबसाइट खोज लीं .. लेकिन समाधान नहीं मिल सका .. कृपया मेरी मदद करो .. धन्यवाद


मुझे Windows पर एक ही त्रुटि का सामना करना पड़ा। इसलिए मैं वर्तमान एसडीके उपकरण संस्करण 2 की स्थापना रद्द कर रहा हूं और नए एसडीके उपकरण (संस्करण 3.0) को स्थापित कर रहा हूं। यह ठीक काम कर रहा है

नए संस्करण के लिए डाउनलोड लिंक http://www.sencha.com/products/sencha-cmd/download


मुझे भी यही समस्या थी। नवीनतम Sencha SDK और विंडोज पर नवीनतम एसडीके उपकरण डाउनलोड, यह चेतावनी संदेश मिला।

यहां समस्या यह थी कि फाइल .senchasdk गायब थी।

सरल समाधान: .senchasdk नामक एक खाली फ़ाइल .senchasdk

बाद में सब कुछ ठीक काम किया।


मुझे सीना सीएमडी के साथ भी यही समस्या थी। मैंने "सेंचाएसडीके टूल्स" को अनइंस्टॉल करके इस समस्या का समाधान किया

मेरे लिए यह अभी ठीक काम करता है


export PATH=~/bin/Sencha/Cmd/ << your sencha cmd version >>  :$PATH

यह आपकी समस्या का समाधान कर सकता है सेन्का को कभी-कभी नए सीकेएम सीडीडी पथ नहीं मिलेगा यदि यह अन्य प्लेटफार्मों पर बनाया गया हो या यदि सीना फोल्डर को कमांड generate के उपयोग के बिना बनाया गया हो