SSIS पैकेज को SQL Server 2008 SP3 पर लागू करें




business-intelligence msdeploy (2)

अगर एक ही समस्या थी, तो पैकेज का संस्करण सिर्फ पुराने संस्करण को सेट करके हल किया गया था:

VersionBuild: <DTS:Property DTS:Name="VersionBuild">87</DTS:Property>
VersionGUID: <DTS:Property DTS:Name="VersionGUID">{E7A9B363-E2DD-40CF-8126-70025D388B2E}</DTS:Property>

सेवा मेरे:

VersionBuild: <DTS:Property DTS:Name="VersionBuild">72</DTS:Property>
VersionGUID: <DTS:Property DTS:Name="VersionGUID">{A82E6DDE-A5CD-4354-9953-31716F572E42}</DTS:Property>

एक जादू की तरह काम करता है!

मेरे पास एक उत्पादन डाटाबेस सर्वर है

"माइक्रोसॉफ्ट एसक्यूएल सर्वर 2008 (एसपी 3) - 10.0.5500.0 (एक्स 64) सितंबर 21 2011 22:45:45 कॉपीराइट (सी) 1988-2008 माइक्रोसॉफ्ट कॉर्पोरेशन वेब संस्करण (64-बिट) विंडोज़ एनटी 6.1 (बिल्ड 7601: सर्विस पैक 1) पर ) "

जब मैं डेटाबेस के लिए अपने पैकेज की तैनाती करने की कोशिश करता हूं, तो मैं विजुअल स्टूडियो 2008 बीआई में एक एसएसआईएस पैकेज का निर्माण करता हूं, मुझे त्रुटि मिलती है

एसक्यूएल सर्वर में संकुल को संग्रहित या संशोधित करने के लिए एसएसआईएस रनटाइम और डाटाबेस को उसी संस्करण की आवश्यकता है। पुराने संस्करणों में संकुल को संग्रहित करना समर्थित नहीं है।

क्या इसे बाद के संस्करण के रूप में माना जा सकता है?

अधिक अपवाद विवरण

संदेश

उपयोगकर्ता के रूप में निष्पादित: DEV-03 \ SYSTEM। माइक्रोसॉफ्ट (आर) SQL सर्वर 64-बिट कॉपीराइट (सी) माइक्रोसॉफ्ट कॉर्पोरेशन 2010 के लिए पैकेज उपयोगिता संस्करण 10.50.2500.0 निष्पादित करें। सभी अधिकार सुरक्षित प्रारंभ: 4:23:16 अपराह्न त्रुटि: 2012-12-11 16: 23: 16.92 कोड: 0xC001700 ए स्रोत:
विवरण: पैकेज में संस्करण संख्या मान्य नहीं है। संस्करण संख्या वर्तमान संस्करण संख्या से अधिक नहीं हो सकती। एंड एरर त्रुटि: 2012-12-11 16: 23: 16.93 कोड: 0xC0016020 स्रोत: वर्णन: संस्करण 6 से संस्करण 3 में पैकेज माइग्रेशन त्रुटि 0xC001700A के साथ विफल "पैकेज में संस्करण संख्या मान्य नहीं है। संस्करण संख्या अधिक नहीं हो सकती मौजूदा संस्करण संख्या की तुलना में। " अंत त्रुटि त्रुटि: 2012-12-11 16: 23: 16.93 कोड: 0xC0010018 स्रोत: विवरण: नोड "डीटीएस: संपत्ति" से लोडिंग मान "6"। त्रुटि त्रुटि 0xC0010014 त्रुटि के कारण पैकेज "C: \ userPath \ SSIS \ FullPackage.dtsx" लोड नहीं कर सका। वर्णन: त्रुटि 0xC0010014 "त्रुटि के कारण लोड करने में विफल रहा है।" एक या एक से अधिक त्रुटि आई है, इस से पहले त्रुटियों का ब्योरा बताते हुए अधिक विशिष्ट त्रुटियां होनी चाहिए। यह संदेश त्रुटियों से संबंधित फ़ंक्शन से रिटर्न मान के रूप में उपयोग किया जाता है। " । यह तब होता है जब CPackage :: LoadFromXML विफल रहता है। स्रोत: शुरू किया गया: 4:23:16 अपराह्न समाप्त: 4:23:16 अपराह्न समाप्त हो गया: 0.265 सेकंड। पैकेज लोड नहीं किया जा सका। कदम विफल हुआ।


आपकी त्रुटि से, ऐसा लगता है कि आप SQL Server 2012 पैकेज को विकसित करने के लिए VS2010 का उपयोग कर रहे हैं और फिर उसे SQL Server 2008 R2 पर लागू करने का प्रयास कर रहे हैं। किसी अन्य प्रश्न पर इस टिप्पणी से, आप देख सकते हैं कि SSIS में संस्करण 6 एसक्यूएल सर्वर 2012 SSIS संस्करण चेकआउट (धन्यवाद @ बिलिंकक) और संस्करण 10.50.2500.0 एसक्यूएल 2008 आर 2 एसपी 1 है। क्या आप वाकई सही मशीन पर और सही मशीन पर तैनाती कर रहे हैं?