ios - Impossibile eseguire l'app in Simulator: Xcode beta 6 iOS 8




10 Answers

L'ho risolto seguendo questi passaggi:

  1. Apri Xcode 6 beta
  2. Vai al menu Xcode> Apri strumento di sviluppo> iOS Simulator
  3. Anche se viene visualizzata una finestra di dialogo di errore, avresti comunque accesso al menu del simulatore iOS
  4. Seleziona Hardware> Dispositivo> Gestisci dispositivi
  5. Clicca sul piccolo segno in basso
  6. Aggiungi (se mancante) tutti i dispositivi che desideri o elimina e ricrea quelli malfunzionanti.
  7. Se qualcuno del simulatore non funziona, fai clic con il pulsante destro del mouse su di esso, quindi eliminalo e quindi ricrearlo di nuovo

Non riesco a lanciare la mia app sul simulatore utilizzando il simulatore xcode 6 beta e iPhone 5s. Prima ricevo un messaggio di errore dal simulatore "Impossibile avviare il simulatore iOS", e dopo che xcode mi mostra l'errore seguente,




Dopo aver trovato alcune soluzioni sul web, una combinazione di procedure ha funzionato per me:

  1. Chiudi Xcode e iOS Simulator (e tutte le applicazioni correlate)

  2. Installa (o reinstalla) Xcode6-Beta nella cartella Applicazioni (direttamente dal file .dmg)

  3. Apri Xcode6-Beta e vai su Xcode -> Preferenze -> Posizioni -> Strumenti della riga di comando e seleziona "Xcode 6.0" (assicurati di aver selezionato quello nella cartella Applicazioni)

  4. Avvia il simulatore iOS e vai su iOS Simulator -> Ripristina contenuto e impostazioni ...

  5. Chiudi tutte le applicazioni e riavvia il tuo Mac (ho deselezionato "Riapri finestre ...")

  6. Apri Xcode6-beta e prova il simulatore iOS

In bocca al lupo




Ciò accade la maggior parte delle volte poiché un'altra istanza del simulatore è in esecuzione nel dock.

Uccidi l'altra istanza e le cose dovrebbero funzionare bene.




Ho avuto questo problema dopo aver rinominato il nome predefinito della cartella "Xcode-Beta2" in "Xcode". Quando l'ho rinominato in "Xcode-Beta2", il simulatore ha funzionato come prima.




Pulisci -> Esegui riparato per me.

Ho provato il resto, niente ha aiutato. Anche se potrebbe essere richiesto anche.




Per quanto mi riguarda, semplicemente non avevo aggiornato XCode dal Centro per gli sviluppatori che ora era Xcode 6 beta 6. Mi ero rovinato con gli aggiornamenti automatici di App Store e mi sono dimenticato del vecchio processo di download manuale.




Ho provato tutto sopra.

Ma ho scoperto che devo aggiornare il più recente OS X 10.10.1 (da OS X 10.9.5) per far funzionare iOS 8.1




Questi passaggi potrebbero aiutarti con il tuo problema. Prova questo:

1 (Fare clic su iOS Simulator nella parte superiore dello schermo

2 (Fare clic su Ripristina contenuto e impostazioni

3 (Fare clic su Ripristina quando viene visualizzato l'avviso

4 (Esegui nuovamente l'app sul simulatore

Questo semplicemente ripristinerà tutti i contenuti e le impostazioni su iOS Simulator in precedenza.

Spero che questo aiuti con l'errore.




Elimina il simulatore / i e crea nuovamente in Xcode / Window / Devices ha funzionato per me ...




Stavo affrontando lo stesso problema, quello che ho fatto è che ho scaricato il simulatore per IOS7 quello che devi fare è andare a: - 1.Xcode-> preferences-> Downloads-> Components 2.after che nel tuo progetto in impostazioni generali-seleziona Obiettivo di distribuzione come 7.0 3. l'ultima cosa è selezionare un simulatore sotto 7.0 :)




Related