ios - with - Errore durante l'installazione di pod con swift




create workspace with cocoapods (3)

Aggiungi "use_frameworks!" al tuo Podfile perché:

Perché Apple non ti permette di costruire librerie statiche che contengono Swift. A differenza di Objective-C, Apple non spedisce le librerie di runtime standard Swift con iOS. Questo disaccoppia la versione della lingua dalla versione della piattaforma. Quando costruisci un'app con Swift, sei tu stesso responsabile della spedizione. Per impostazione predefinita, Xcode usa swift-stdlib-tool per gestire la copia dei dylibs di runtime di Swift, ma gli strumenti non sono sufficienti quando si tenta di spedire framework che usano Swift con un'app che è solo Objective-C. Il tuo eseguibile dell'app e i framework spediti utilizzeranno tutti lo stesso set di dylibs, che sono incorporati nella sottodirectory Framework del bundle dell'applicazione.

Innanzitutto, è perché non puoi collegarti a versioni diverse delle librerie standard. Inoltre, è preferibile incorporarli una sola volta e non più volte, a causa dei vincoli alle dimensioni della memoria e alla velocità della rete, che sono rilevanti per la distribuzione. È possibile integrare CocoaPods nel proprio progetto tramite framework anziché librerie statiche specificando use_frameworks !. Se questo non è presente, non sarai in grado di integrare le dipendenze, se dipendi da un pod che include il codice sorgente Swift.

Riferimento: http://blog.cocoapods.org/CocoaPods-0.36/

Ho seguito le istruzioni di Cocoapods.

Di seguito è il mio Podfile:

platform :ios, '8.2'

pod 'SwiftyJSON', '~> 2.1'
pod 'SwiftSpinner', '~> 0.6'
pod 'Alamofire', '~> 1.1'
pod 'SuperRecord', '~> 1.2'
pod 'Toucan

Quando ho fatto l' installazione pod ho ricevuto il seguente errore:

I pod scritti in Swift possono essere integrati solo come framework; questa funzione è ancora in beta. Aggiungi use_frameworks! al tuo Podfile o target per scegliere di usarlo.

aggiornato:

Di seguito è riportato il log della mia console:

$ pod install
Analyzing dependencies
Downloading dependencies
Installing Alamofire (1.1.4)
Installing SuperRecord (1.2)
Installing SwiftSpinner (0.6.0)
Installing SwiftyJSON (2.1.3)
Installing Toucan (0.2.0)
[!] Pods written in Swift can only be integrated as frameworks; this feature is still in beta. Add `use_frameworks!` to your Podfile or target to opt into using it.

Aggiungi "use_frameworks!" al tuo Podfile:

Si prega di vedere sotto Podfile di esempio

target 'MySample' do

  pod 'AFNetworking', '~> 2.5'

  pod 'Net', '~> 0.2' #This is a sample in Swift

  use_frameworks! # <--Use this line
end

la soluzione è molto semplice. Devi solo aggiungere queste linee al tuo file pod:

target 'PassDTAFirebase' do

  inherit! :complete

    # Here your pods

  use_frameworks! 

end