Installazione di rgl su Ubuntu e Mac: X11 non trovato




linux macos (5)

Mi ci è voluto molto tempo per capirlo su [RHEL 3.10.0-862.14.4.el7.x86_64 x86_64 x86_64 x86_64 GNU / Linux]. Sono richiesti i seguenti pacchetti:

libpng12-devel.x86_64
ImageMagick-c++-devel.x86_64
mesa-libGLU-devel.x86_64
libselinux-devel.x86_64
xorg-x11-apps

Ho visto questa domanda qui: errore nel caricamento del pacchetto rgl con Mac OS X ma non si fa menzione dell'errore di installazione, che è il mio caso. Non riesco a installare il pacchetto rgl , usando questo comando in R :

source("http://bioconductor.org/biocLite.R")
biocLite("rgl")

Viene visualizzato il seguente errore:

configure: errore: X11 non trovato ma richiesto, configurazione interrotta. ERRORE: configurazione non riuscita per il pacchetto 'rgl' * rimozione '/Library/Frameworks/R.framework/Versions/3.2/Resources/library/rgl'

Ho controllato questo indirizzo /Library/Frameworks/R.framework/Versions/3.2/Resources/library e non esiste una cartella rgl , quindi non posso eliminare aglrgl.so (o rgl.so ), che è la risposta a quanto sopra menzionato domanda. Potete per favore aiutarmi con questo problema di installazione? Grazie.


Non sono sicuro del caso Mac, ma su Windows ho riscontrato problemi durante il download dello stesso pacchetto rgl. L'installazione di RGL richiede il pacchetto devtools

install.packages("devtools")
library(devtools)
install.packages("rgl")
library(rgl)

Su OpenSuse

sudo zypper install xorg-x11-devel
sudo zypper install glu-devel

Su Ubuntu, quello che ha funzionato per me è stato installare il pacchetto direttamente dalla riga di comando:

sudo apt-get install r-cran-rgl

(Abbiamo una strana configurazione qui, quindi YMMV)


Tutte le risposte menzionate sono corrette; tuttavia, nessuno è per Mac.

Nel mio caso (sono un utente Mac), ho risolto il problema installando XQuartz e riavviando R.





rgl