node.js - rolling - v8 debug 0.4 6 install node pre gyp install-- fallback to build npm err exit status 1




`node-pre-gyp install--fallback-to-build` fallito durante l'installazione di MeanJS su OSX (6)

Bene, dopo alcune operazioni di debug, le seguenti dipendenze utilizzano una versione precedente di touch :

./node_modules/bower/node_modules/decompress-zip/package.json:    "touch": "0.0.3"
./node_modules/bower/node_modules/lockfile/package.json:    "touch": "0"
./node_modules/gulp-nodemon/node_modules/nodemon/package.json:    "touch": "1.0.0",
./node_modules/gulp-nodemon/node_modules/touch/package.json:    "touch": "./bin/touch.js"
./node_modules/nodemon/package.json:    "touch": "~0.0.3",

Con ciò sono riuscito a ottenere meanJS lavorando con il nodo 5.

Ecco la cronologia dei comandi che ho eseguito:

git clone https://github.com/meanjs/mean.git
cd mean
nvm install 5
nvm use 5
npm install
which node-gyp
npm install -g node-pre-gyp
sudo xcodebuild -license
npm install

Aveva alcuni problemi e poi:

Ho aggiunto la seguente riga:

#!/usr/bin/env node

./mean/node_modules/.bin/touch file ./mean/node_modules/.bin/touch

E poi:

npm install

E, naturalmente, prima di riprovare, è possibile sudo rm -rf ./node_modules && npm cache clean un file sudo rm -rf ./node_modules && npm cache clean .

Mi sono appena comprato un mac book dopo aver usato Windows per molto tempo.

Stavo cercando di lavorare a un progetto MeanJS su cui stavo lavorando. npm install sul progetto genera errori

Failed to execute '/usr/local/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/Users/Aayush/Work/lishn/repo/lishn-alpha/node_modules/grunt-node-inspector/node_modules/node-inspector/node_modules/v8-debug/build/debug/v0.4.6/node-v46-darwin-x64/debug.node --module_name=debug --module_path=/Users/Aayush/Work/lishn/repo/lishn-alpha/node_modules/grunt-node-inspector/node_modules/node-inspector/node_modules/v8-debug/build/debug/v0.4.6/node-v46-darwin-x64' (1)
npm ERR! Darwin 15.0.0
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install"
npm ERR! node v4.1.1
npm ERR! npm  v2.14.4
npm ERR! code ELIFECYCLE
> 
> npm ERR! v8-[email protected].4.6 install: `node-pre-gyp install --fallback-to-build`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the v8-[email protected].4.6 install script 'node-pre-gyp install --fallback-to-build'.
npm ERR! This is most likely a problem with the v8-debug package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-pre-gyp install --fallback-to-build
npm ERR! You can get their info via:
npm ERR!     npm owner ls v8-debug
npm ERR! There is likely additional logging output above.

Ho provato a svuotare la cache.

Ho provato ad installare node-pre-gyp con sudo e --unsafe-perm

Ho anche provato a installare un progetto MEAN, con lo stesso errore.

Non riesco a trovare quale sia il problema qui.

Node Version - 5.0.0

NPM Version - 3.3.10

Come @ ocean800 ha dichiarato che ho aggiornato il nodo. La soluzione seguente è per Ubuntu 16.04 che ha funzionato per me, ma qualcosa di simile su OSX può risolvere questo problema.

Su Ubuntu 16.04, ciò che ha funzionato per me era l'aggiornamento del nodo

aggiornamento di nodejs su ubuntu 16.04

Sto replicando la soluzione dal link qui sotto

Per aggiornare, è possibile installare n

sudo npm install -g n

Quindi solo:

sudo n latest

o una versione specifica

sudo n 8.9.0

Quindi provare e installare

sudo npm install <package>

Questo sembra un problema con l'aggiornamento del mio nodo. Come mai l'ho risolto con il seguente approccio.

Per prima cosa disinstallare il cli, svuotare il pacchetto e reinstallare con questi comandi

npm uninstall -g @angular/cli
npm cache clean
npm install -g @angular/cli

Quindi installare node-pre-gyp

npm install -g node-pre-gyp

Riavvia il tuo terminale e verifica se il problema è risolto.


Spero che il mio scenario possa aiutare qualcun altro. Ho avuto lo stesso problema con il pacchetto bcrypt. Innanzitutto, ho provato con npm i -g node-gyp come suggerito da Anne ma il problema persisteva. Quindi ho letto di nuovo il messaggio di errore per comprendere meglio il problema e ho scoperto che lo script non riesce a compilare il pacchetto da zero, poiché non esiste una versione precompilata. In particolare, non riesce a trovare il comando g ++, quindi ho risolto l'installazione del pacchetto build-essential con sudo apt install build-essential -y .


russfrisch ha commentato 4 giorni fa:

Stavo vivendo lo stesso problema. Cambiando la versione per grunt-node-inspector per anteporre un "> =" al posto di un "~", questo ha funzionato correttamente.

Collega alla pagina github dove ho trovato questa soluzione.

Link al mio post su


stai facendo l'esempio dalla cartella node_modules?

Non dovrebbero essere scappati da lì.

Crea invece il seguente file sul tuo progetto:

post-data.js

var Curl = require( 'node-libcurl' ).Curl,
   querystring = require( 'querystring' );

var curl = new Curl(),
  url  = 'http://posttestserver.com/post.php',
data = { //Data to send, inputName : value
    'input-arr[0]' : 'input-arr-val0',
    'input-arr[1]' : 'input-arr-val1',
    'input-arr[2]' : 'input-arr-val2',
    'input-name' : 'input-val'
};

//You need to build the query string, 
// node has this helper function, but it's limited for real use cases (no support for 
array values for example)
data = querystring.stringify( data );

 curl.setOpt( Curl.option.URL, url );
 curl.setOpt( Curl.option.POSTFIELDS, data );
 curl.setOpt( Curl.option.HTTPHEADER, ['User-Agent: node-libcurl/1.0'] );
 curl.setOpt( Curl.option.VERBOSE, true );

 console.log( querystring.stringify( data ) );

 curl.perform();

 curl.on( 'end', function( statusCode, body ) {

console.log( body );

this.close();
});

curl.on( 'error', curl.close.bind( curl ) );

Esegui con il nodo post-data.js

ref: https://github.com/JCMais/node-libcurl/issues/98





meanjs