android - Errore Gradle: la versione Gradle minima supportata è 3.3. La versione attuale è 3.2




android-studio android-gradle (11)

Risposta aggiornata: per Android Studio 3.1 e versioni successive

Per Android Studio 3.1 e versioni successive, distributionUrl è stato aggiornato alla versione 4.6 dalla versione 4.4 . Il tuo gradle-wrapper.properties dovrebbe assomigliare a questo:

#DATE
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-4.6-all.zip

Risposta aggiornata:

Per Android Studio 3.0 e versioni successive, distributionUrl è stato aggiornato alla versione 4.1 dalla versione 3.3 . Il tuo gradle-wrapper.properties dovrebbe assomigliare a questo:

#DATE
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-4.1-all.zip

Risposta originale:

#DATE
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-3.3-all.zip

Quando oggi aggiorno Android Studio scrive: la versione minima supportata di Gradle è 3.3. La versione corrente è 3.2 come posso risolvere questo problema?

Ecco il mio build.gradle

// Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.3.0'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

e secondo build.gradle:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 25
    buildToolsVersion "25.0.0"
    defaultConfig {
        applicationId "com.tosi.ex"
        minSdkVersion 14
        targetSdkVersion 25
        versionCode 1
        versionName "1.0"
        multiDexEnabled true
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
    sourceSets { main { assets.srcDirs = ['src/main/assets', 'src/main/assets/'] } }
}
repositories {
    mavenCentral()
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })
    compile 'com.android.support:appcompat-v7:25.2.1'
    compile 'com.android.support:design:25.2.1'
    compile 'com.github.ksoichiro:android-observablescrollview:1.5.0'
    compile 'com.android.support:support-v4:25.2.1'
    compile 'com.android.support:mediarouter-v7:25.2.1'
    compile 'com.google.android.gms:play-services:10.2.1'
    compile 'com.android.support:cardview-v7:25.2.1'
    compile 'com.squareup.picasso:picasso:2.5.2'
    compile 'uk.co.chrisjenx:calligraphy:2.2.0'
    testCompile 'junit:junit:4.12'
}

gradle-wrapper.properties:

#Tue Mar 28 17:26:02 CEST 2017
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-3.2-all.zip

Quando ho cambiato le proprietà distributionUrl in 3.3-all.zip bloccato in aggiornamento non so cosa fare con questo problema. Per favore aiutatemi Grazie mille


Aggiorna Android Studio e Gradle. La modifica della rispettiva versione aggiornata aggiornata nel file build.gradle ha funzionato per me.


Apri gradle-wrapper.properties

distributionUrl=https\://services.gradle.org/distributions/gradle-3.3-all.zip

cambiarlo in

distributionUrl=https\://services.gradle.org/distributions/gradle-4.4-all.zip

Assicurati di utilizzare il wrapper gradle predefinito in Apri file> Impostazioni> Build, Execution, Deployment> Build Tools> Gradle.


Informazioni sulla versione del plug-in Android Studio Gradle e sulla versione Gradle obbligatoria, puoi vedere una risposta più dettagliata qui: .com/a/51392464/8034839

Per ogni versione di questo plugin Gradle, richiede una versione minima di Gradle come elencato nella tabella seguente

(Pagina di riferimento: gradle-plugin#updating-gradle ).

Quando aggiorni Android Studio, potresti ricevere una richiesta per aggiornare Gradle anche all'ultima versione disponibile.

Ad esempio, Android Gradle Plugin versione 3.1.0+ richiede una versione minima Gradle 4.4.

Puoi essere configurato tramite File Android Studio -> Struttura del progetto -> Progetto . Vedi sotto:

Oppure puoi modificare manualmente il file gradle/wrapper/gradle-wrapper.properties . Per esempio:

distributionUrl = https\://services.gradle.org/distributions/gradle-4.6-all.zip

Messaggio di errore: sincronizzazione Gradle non riuscita: la versione Gradle minima supportata è 4.9. La versione attuale è 4.1-milestone-1. Se si utilizza il gradle wrapper, provare a modificare il distributionUrl in SampleProj / app / gradle / wrapper / gradle-wrapper.properties in gradle-4.9-all.zip

Sto usando Android Studio IDE versione 3.2 beta 2.

Soluzione: quando apriamo il file gradle-wrapper.properties in IDE mostra la distribuzione corretta di URL. ma originariamente non è stato aggiornato. Quindi modifica manualmente la proprietà distributionUrl.

Esempio: apri un file gradle-wrapper.properties nel blocco note o in qualsiasi altro editor. /Project/app/gradle/wrapper/gradle-wrapper.properties e modifica la proprietà distributionUrl in questo modo

distributionUrl=https\://services.gradle.org/distributions/gradle-4.9-all.zip

Per Android Studion versione 3.3.2

1) Ho aggiornato l'URL di distributionUrl=https\://services.gradle.org/distributions/gradle-4.10.1-all.zip in gradle-wrapper.properties file gradle in distributionUrl=https\://services.gradle.org/distributions/gradle-4.10.1-all.zip in gradle-wrapper.properties file

2) All'interno del file build.gradle di livello superiore aggiornato il plugin gradle alla versione 3.3.2

dependencies {
    classpath 'com.android.tools.build:gradle:3.3.2'
    classpath 'com.google.gms:google-services:4.2.0'
}

Poiché questo è il primo risultato di Google questo errore, voglio ricordare che è sufficiente fare clic sul collegamento blu del messaggio di errore della finestra in basso "Correggi le impostazioni del wrapper Gradle e reimporta il progetto" per te ora.


apri il file gradlew con Android Studio, tutto verrà scaricato


devi scaricare la versione più recente da https://gradle.org/releases successivamente vai su file / struttura / progetto del progetto e metti la nuova versione in versione graduale


  • modificato distrubutionUrl da 4.1 a 4.4

  • ha cambiato la versione gradle build in 3.1.1 sotto project / android

per me va bene.





build.gradle