javascript - tattoo - nodo infinito tibetano




nodo: errore di trasferimento: nodo: simbolo SSL_set_cert_cb, versione libssl.so.10 non definito nel file libssl.so.10 con riferimento temporale del collegamento (2)

Grazie, dopo l'aggiornamento di yum openssl potrei eseguire con successo

npm install angular

npm: errore di trasferimento: npm: simbolo SSL_set_cert_cb, versione libssl.so.10 non definito nel file libssl.so.10 con riferimento temporale del collegamento

yum update openssl

npm install angular

[email protected] / home / mapr / MS / angularjs-springmvc-sample-boot-master 7

└── [email protected] 1.6.6

Funzionando bene.

Ho eseguito un server NodeJS per un sito Web utilizzando lo stack MEAN per un sito Web ed è in esecuzione da alcuni mesi. Quando ho iniziato a lavorarci di nuovo stamattina, ho avviato il sito con:

nodemon server/app.js

Il server Express si avvia correttamente, ma non appena mi collego ad esso con il mio browser, ottengo il seguente errore:

nodo: errore di trasferimento: nodo: simbolo SSL_set_cert_cb, versione libssl.so.10 non definito nel file libssl.so.10 con riferimento al tempo di collegamento [nodemon] impossibile avviare il processo, "nodo" exec non trovato`

E quando faccio node server/app.js , ottengo lo stesso node: relocation error... , ma non riesco a ...failed to start process...

Non penso che sia con le modifiche che ho apportato nei giorni scorsi, perché sono andato su un altro server su cui era in esecuzione (dove il codice aveva poche settimane), e ho riavviato il processo nodejs, e poi rotto quando ho visitato il sito.

versione npm: 3.10.10, versione del nodo: 6.11.3, versione di CentOS Linux 7.3.1611


Ho avuto lo stesso problema con un modulo di ursa che nello stesso ambiente.

La ricostruzione di NPM ha il seguente errore quando la mia versione di openssl è 1.0.1e

node-gyp: relocation error: node-gyp: symbol SSL_set_cert_cb, version libssl.so.10 not defined in file libssl.so.10 with link time reference

Ho aggiornato openssl con yum update openssl a 1.0.2k , quindi la npm rebuild non ha più npm rebuild .





npm-install