android - support - gradle version download




Impossibile risolvere la dipendenza per ": app @ debug/compileClasspath": impossibile risolvere com.android.support:appcompat-v7:26.1.0 (10)

Impossibile risolvere la dipendenza per ": app @ debug / compileClasspath": impossibile risolvere com.android.support:appcompat-v7:26.1.0.

Impossibile risolvere com.android.support:appcompat-v7:26.1.0.

Richiesto da: progetto: app

Nessuna versione cache di com.android.support:appcompat-v7:26.1.0 disponibile per la modalità offline.

Registro degli errori:

Impossibile risolvere tutti i file per la configurazione ': app: debugCompileClasspath'.
Impossibile risolvere com.android.support:appcompat-v7:26.1.0.
Richiesto dalla:
progetto: app
Nessuna versione cache di com.android.support:appcompat-v7:26.1.0 disponibile per la modalità offline.
Nessuna versione cache di com.android.support:appcompat-v7:26.1.0 disponibile per la modalità offline.
Impossibile risolvere com.android.support.constraint: layout di vincolo: 1.1.0-beta3.
Richiesto dalla:
progetto: app
Nessuna versione cache di com.android.support.constraint: layout vincoli: 1.1.0-beta3 disponibile per la modalità offline.
Nessuna versione cache di com.android.support.constraint: layout vincoli: 1.1.0-beta3 disponibile per la modalità offline.
Impossibile risolvere com.android.support:design:26.1.0.
Richiesto dalla:
progetto: app
Nessuna versione cache di com.android.support:design:26.1.0 disponibile per la modalità offline.
Nessuna versione cache di com.android.support:design:26.1.0 disponibile per la modalità offline.
Impossibile risolvere com.android.support:cardview-v7:26.1.0.
Richiesto dalla:
progetto: app
Nessuna versione cache di com.android.support:cardview-v7:26.1.0 disponibile per la modalità offline.
Nessuna versione cache di com.android.support:cardview-v7:26.1.0 disponibile per la modalità offline.
Impossibile risolvere com.google.android.gms: play-services-ads: 11.4.2.
Richiesto dalla:
progetto: app
Nessuna versione cache di com.google.android.gms: play-services-ads: 11.4.2 disponibile per la modalità offline.
Nessuna versione cache di com.google.android.gms: play-services-ads: 11.4.2 disponibile per la modalità offline.
Impossibile risolvere com.android.support:support-v4:26.1.0.
Richiesto dalla:
progetto: app
Nessuna versione cache di com.android.support:support-v4:26.1.0 disponibile per la modalità offline.
Nessuna versione cache di com.android.support:support-v4:26.1.0 disponibile per la modalità offline.

Immagine registro errori:


Per gli utenti che hanno gusti nel progetto e hanno trovato questa discussione:

Si noti che se la dipendenza del modulo ha sapori diversi, è necessario utilizzare una delle strategie:

  1. Il modulo che restringe le dipendenze dovrebbe avere gli stessi sapori e dimensioni del modulo delle dipendenze
  2. Dovresti indicare esplicitamente quale configurazione scegli come target nel modulo

Come quello:

dependencies {
    compile project(path: ':module', configuration:'alphaDebug') 
}

Opzione Invalidate Cache & Restart valida Invalidate Cache & Restart da file.

Deselezionando la modalità offline non ha funzionato per me.


Dalle documentations :

Aggiungi la libreria di supporto alla sezione delle dipendenze. Ad esempio, per aggiungere la libreria v4 core-utils, aggiungere le seguenti righe:

dependencies {
    ...
    implementation "com.android.support:support-core-utils:28.0.0"
}

Di seguito è illustrata una soluzione demo di; Deseleziona l'opzione di lavoro offline andando a:

File -> Impostazioni -> Build, Execution, Deployment -> Gradle

Se la soluzione precedente non funziona, prova questo:

  1. Apri il file build.gradle per la tua applicazione.

  2. Assicurati che la sezione dei repository includa una sezione maven con l'endpoint " https://maven.google.com ". Per esempio:

    allprojects {
         repositories {
             jcenter()
             maven {
                 url "https://maven.google.com"
             }
         }
    }
  3. Aggiungi la libreria di supporto alla sezione delle dependencies . Ad esempio, per aggiungere la libreria v4 core-utils, aggiungere le seguenti righe:

    dependencies {
        ...
        compile "com.android.support:support-core-utils:27.1.0"
    }

Attenzione: l' uso di dipendenze dinamiche (ad esempio palette-v7:23.0.+ ) Può causare aggiornamenti imprevisti della versione e incompatibilità di regressione. Si consiglia di specificare esplicitamente una versione della libreria (ad esempio palette-v7:27.1.0 ).

Modifiche alla dichiarazione manifest

In particolare, è necessario aggiornare l'elemento android:minSdkVersion del <uses-sdk> nel manifest al nuovo numero di versione inferiore, come mostrato di seguito:

<uses-sdk
  android:minSdkVersion="14"
  android:targetSdkVersion="23" />

Se si utilizzano i file di build Gradle, l'impostazione minSdkVersion nel file di build sovrascrive le impostazioni manifest.

apply plugin: 'com.android.application'

android {
   ...
      defaultConfig {
            minSdkVersion 16
            ...
        }
        ...
    }

A seguito del supporto della libreria per sviluppatori Android .


Ho risolto il problema In Home Ubuntu, ho eliminato la cartella .gradle e scaricata di nuovo. Spero sia utile


Oggi ho il problema simile.

Precedente nel mio grado di progetto

// Top-level build file where you can add configuration options common to all 
sub-projects/modules.
allprojects {
repositories {
    jcenter()
    google()
    mavenCentral()
    maven { url "https://jitpack.io" }
    maven { url 'https://plugins.gradle.org/m2/'}
}}

Quindi ho appena aggiunto questo sotto la riga in tutti i progetti

maven {
        url "https://maven.google.com"
    }

Mi ha salvato la giornata.

E ora il mio attuale codice allproject {} è simile al seguente

allprojects {
repositories {
    jcenter()
    google()
    mavenCentral()
    maven { url "https://jitpack.io" }
    maven { url 'https://plugins.gradle.org/m2/'}
    maven {
        url "https://maven.google.com"
    }
}}

Se non hai deselezionato il lavoro offline , assicurati di disporre di Internet per Android Studio per normalizzare il tuo progetto.


Se ricevi lo stesso errore dopo aver aggiunto il modulo dinamico, non preoccuparti segui questo:

  • Aggiungi productFlavors nel tuo build.gradle (modulo dinamico)

    productFlavors {
    flavorDimensions "default"
    stage {
       // to do
    }
    prod {
       // to do
    
     }
    }

Vai su File->Other Settings->Default Settings->Build, Execution, Deployment->Build Tools->Gradle->Uncheck Offline work option.


usa Invalidate Caches/Restart non valide Invalidate Caches/Restart funzionerà per te e assicurati che l'opzione di sincronizzazione offline gradle non sia abilitata





android-gradle