python - Matplotlib: Naso, Tornado




python set axis label (2)

Dopo alcune ricerche ho trovato un modo per installare i pacchetti senza controllare la versione corrente, ad esempio, per l'installazione di matplotlib :

sudo -H pip install --ignore-installed matplotlib

Non sono sicuro che ci sia un modo migliore, ma in affitto mi permette di continuare a lavorare. spero possa essere d'aiuto

Perché sto cercando di installare jupyter sul mio Mac, ho migliorato il mio pip. Mi ha mostrato che va tutto bene, ma poi ho notato questo:

    Requirement already up-to-date: pip in /Library/Python/2.7/site-packages/pip-10.0.0b2-py2.7.egg (10.0.0b2)
     matplotlib 1.3.1 requires nose, which is not installed.
     matplotlib 1.3.1 requires tornado, which is not installed.
     matplotlib 1.3.1 has requirement numpy>=1.5, but you'll have numpy 1.8.0rc1 which is incompatible.

Cosa significa questo? Il mio matplotlib funzionerà normalmente anche se non ho num => 1.5?

Ho provato a risolverlo come suggerito matplotlib 1.3.1 ha requisito numpy> = 1.5, ma avrai numpy 1.8.0rc1 che è incompatibile ma non funziona:

sudo -H pip install numphy

Password:
Requirement already satisfied: numphy in /Library/Python/2.7/site-packages (0.0.1)
matplotlib 1.3.1 requires nose, which is not installed.
matplotlib 1.3.1 requires tornado, which is not installed.
matplotlib 1.3.1 has requirement numpy>=1.5, but you'll have numpy 1.8.0rc1 which is incompatible.

Ho avuto lo stesso problema. Devi installare le suddette dipendenze. Quali sono la versione nasale, a tornado e numpy maggiore di 1.5 Effettuare quanto segue

sudo easy_install nose
sudo easy_install tornado

Per quanto riguarda l'ultima parte riguardante la versione numpy maggiore di 1.5 devi ottenere l'ultima versione di python. Fare riferimento a qui





jupyter