java - what - www eclipse




Errore interno Eclipse "Feed news polling" (2)

Ciò è causato da http://openjdk.java.net/jeps/320 , che è la rimozione di Java EE e moduli CORBA dalla versione standard di Java 11.

Come accennato da @Pyves, il modo semplice sarebbe deselezionare "Abilita il polling automatico delle notizie" da Preferenze-> Generale -> Notizie

Ma se hai ancora bisogno di questo, puoi installare i bundle "javax. *" Dal repository dell'orbita eclipse. Ecco l'ultimo URL di repository stabile: http://download.eclipse.org/tools/orbit/downloads/drops/R20180905201904/repository

Sto usando Eclipse (4.9.0) sul mio MacBook (High Sierra, Java 11) e questo errore viene visualizzato a volte, se sono su un'altra app, gli errori creano uno "stack" come vedi nello screenshot, è fastidioso tornare su Eclipse e chiudere questo errore ogni volta. Qualcuno può aiutarmi a risolvere questo?


La disattivazione del feed di notizie risolve questo problema (Per @Pyves, deselezionando "Abilita polling automatico delle notizie" da Preferenze-> Generale -> Notizie), ma tieni presente che potresti avere altri problemi a causa del troppo nuovo JDK. Noga Rotman ha appena trascorso diverse ore a capire che Eclipse non è stato in grado di trovare JUnit, anche se è stato installato e correttamente sul percorso di classe, a causa dell'utilizzo del nuovo JDK (quello che sta causando questi stessi problemi).

È possibile risolvere il problema sottostante disinstallando la versione corrente di JDK e installando una versione precedente, quindi reinstallando Eclipse. Se disponi di Oracle JDK, puoi trovare le istruzioni di disinstallazione here e Java SE Development Kit 8u191 (che ha risolto i miei problemi) è here .





eclipse-2018-09