Aggiunta la fase Esegui script a Xcode, ma non succede nulla




build (2)

Ho aggiunto una fase di compilazione Run Script al mio progetto Xcode, lo script è giusto

echo "Hello"

Non sto vedendo ciao nella console di debug o altro, quindi immagino che il mio script non venga eseguito quando costruisco.

Qualche idea ?

(Modifica: il navigatore mostra solo)

GNU gdb 6.3.50-20050815 (Apple version gdb-1708) (Mon Aug  8 20:32:45 UTC 2011)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-apple-darwin".sharedlibrary apply-load-rules all
Attaching to process 1955.
**** UNIT TESTS ****
Success: 33 tests passed.
Test time: 0.02 seconds.
********************
[Switching to process 1955 thread 0x13c13]

In Xcode 6: View -> Navigators -> Show Report Navigator

Sulla colonna di sinistra, sotto la scheda By Group , seleziona l'ultima Build per qualsiasi target appena creato.

Nella colonna centrale, seleziona la scheda All Messages , l'output del tuo script di compilazione dovrebbe essere da qualche parte lì dentro.


Vedrai l'output nel log di costruzione.

Dopo che la compilazione ha avuto successo, vai su "Visualizza -> Navigatori -> Mostra navigatore di report" ( cmd + 8 ) e controlla il registro più recente.





build