tgz - status rubygems




10.10ヨセミテにtherubyracer gemをインストールするには? (11)

2018年の回答が更新されました。

私はHigh Sierraにいる、Homebrew 1.6.1

brew install v8-315

gem install libv8 -v '3.16.14.13' -- --with-system-v8
gem install therubyracer -- --with-v8-dir=/usr/local/opt/[email protected]/

何が私のために働いたのですか?

彼の元の答えには、信用が詰まっています 。

私はヨセミテ10.10にtherubyracer gemをインストールすることはできません。

ここにログがあります:

11:53  $ gem install libv8 -v '3.16.14.3' -- --with-system-v8


Building native extensions with: '--with-system-v8'
This could take a while...
Successfully installed libv8-3.16.14.3
Parsing documentation for libv8-3.16.14.3
Installing ri documentation for libv8-3.16.14.3
Done installing documentation for libv8 after 0 seconds
1 gem installed


02:05  $ gem install therubyracer -v '0.12.1' -- --with-system-v8


Building native extensions with: '--with-system-v8'
This could take a while...
ERROR:  Error installing therubyracer:
    ERROR: Failed to build gem native extension.

    /usr/local/var/rbenv/versions/2.1.2/bin/ruby extconf.rb --with-system-v8
checking for main() in -lpthread... yes
checking for main() in -lobjc... yes
checking for v8.h... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/usr/local/var/rbenv/versions/2.1.2/bin/ruby
    --with-pthreadlib
    --without-pthreadlib
    --with-objclib
    --without-objclib
    --enable-debug
    --disable-debug
    --with-v8-dir
    --without-v8-dir
    --with-v8-include
    --without-v8-include=${v8-dir}/include
    --with-v8-lib
    --without-v8-lib=${v8-dir}/lib
/usr/local/var/rbenv/versions/2.1.2/lib/ruby/gems/2.1.0/gems/libv8-3.16.14.3/ext/libv8/location.rb:50:in `configure': You have chosen to use the version of V8 found on your system (Libv8::Location::System::NotFoundError)
and *not* the one that is bundle with the libv8 rubygem. However,
it could not be located. please make sure you have a version of
v8 that is compatible with 3.16.14.3 installed. You may
need to special --with-v8-dir options if it is in a non-standard
location

thanks,
The Mgmt

    from /usr/local/var/rbenv/versions/2.1.2/lib/ruby/gems/2.1.0/gems/libv8-3.16.14.3/lib/libv8.rb:7:in `configure_makefile'
    from extconf.rb:32:in `'

extconf failed, exit code 1

Gem files will remain installed in /usr/local/var/rbenv/versions/2.1.2/lib/ruby/gems/2.1.0/gems/therubyracer-0.12.1 for inspection.
Results logged to /usr/local/var/rbenv/versions/2.1.2/lib/ruby/gems/2.1.0/extensions/x86_64-darwin-14/2.1.0-static/therubyracer-0.12.1/gem_make.out

これはlibv8とのいくつかの競合のためにも起こりますが、rubyracerにバージョンを割り当ててインストールすることはできますが、

gemfileで次のように変更します。

gem 'therabyracer'、 '〜> 0.12.1'

バンドルインストールを実行する


これは私のヨセミテとRuby 2.1.5(RubyからRVM)

gem install libv8 -v '3.16.14.3' -- --with-system-v8

以前はそれが私にエラーを与えていたGem::Ext::BuildError: ERROR: Failed to build gem native extension.できませんGem::Ext::BuildError: ERROR: Failed to build gem native extension. libv8 gemバージョン3.16.14.3用


たぶんそれは誰かには役に立ちますが、私がインストールしたすべてのlibv8をアンインストールするのが解決策でした(私のlibv8の問題のために)theruraracerのインストールに問題がありました。 ブログ

$ gem uninstall libv8
$ gem install therubyracer -v '0.12.0'
Fetching: libv8-3.16.14.7-x86_64-darwin-14.gem ( 57%)
Fetching: libv8-3.16.14.7-x86_64-darwin-14.gem (100%)
Successfully installed libv8-3.16.14.7-x86_64-darwin-14
Building native extensions.  This could take a while...
Successfully installed therubyracer-0.12.0
2 gems installed

私はこれが誰かを助けることを望む。


今回は私の答えはありません。 私はあまりにもこれを使用している:

brew tap homebrew/versions
brew install v8-315

gem install libv8 -v '3.16.14.13' -- --with-system-v8
gem install therubyracer -- --with-v8-dir=/usr/local/opt/v8-315

bundle install

rubyracer github問題を見てください。

他の人に役立つことを願っています。


彼らはlibv8の最新バージョンでこの問題を修正しました。 参照: https://github.com/cowboyd/libv8/issues/123 : https://github.com/cowboyd/libv8/issues/123

githubリポジトリからインストールする必要があります。このgem "libv8", git: "git://github.com/cowboyd/libv8.git", submodules: true

編集:

これは明らかに問題のいくつかを解決するだけです。 私はlibv8の新しいバージョンをインストールしましたが、今はRubyracerが私が思う他のものを探していますか? それでも探している。


私のヨセミテ、Ruby 2.1.2でこれが私のためにしか機能しません:

gem install libv8 -v '3.16.14.3' -- --with-system-v8
brew link --overwrite v8-315 --force
gem install therubyracer -v '0.12.2' -- --with-system-v8

私の問題を抱えている可能性のある人には頭を下げる:RVMでRubyのバージョンをアンインストールしてから、再インストールした。 それは、ルビをコンパイルするための最新バージョンのxcodeツールで、正しい依存関係を使用していたようです。

rvm list
rvm uninstall ruby-x.x.x
rvm install ruby-x.x.x

私は次のことをした

gem install therubyracer

これにより、エラーなしでインストールされた依存関係libv8 (3.16.14.7 x86_64-darwin-14)をインストールするtherubyracer 0.12.1がインストールされます。

私はruby 2.1.5を使ってインストールしました。

CC=/usr/bin/gcc rbenv install 2.1.5

それは私がbrew upgrade ruby-builds実行した後に行ったものです。

ruby 2.1.5インストールした後、私はまた走った

gem upgrade --system

rubygems-update 2.4.5を入手rubygems-update 2.4.5


試してみた後、単にルビーをアップグレードしてみました。

brew install ruby 

gemファイルに次の行を追加します。

gem 'libv8'  
gem 'therubyracer' 

git clone https://github.com/cowboyd/libv8.git
cd libv8
bundle install
bundle exec rake clean build binary
gem install pkg/libv8-3.16.14.3-x86_64-darwin-12.gem #note that libv8 version may change, so tab through files in pkg/, also remember to use the one with version specified

あなたのプロジェクトの宝石をバンドルするだけです

これは10.10(ruby 2.1.2)で私のために働いた唯一の方法です





rubygems