ruby on rails - stable - どのように "あなたのRubyのバージョンは2.3.0ですが、Gemfileは2.2.5を指定しました"




rubygem s (5)

サーバーを実行しているときにこのエラーが発生していますが、これをどのように修正しますか?


2.2.5をすでにインストールしていて、現在のRubyバージョンとして設定していても、Rubyバージョン2.3.0がインストールされていなくても同じエラーを表示している場合は、単にバンドラをインストールしてください。

gem install bundler

その後:

bundle install

rbenvを使用している場合は、ローカルまたはグローバルなルビーバージョンを設定した後で、 "rbenv rehash"コマンドを実行してください。 それは私の問題を解決しました。

rbenv rehash

あなたのGemfileには行があります

ruby '2.2.5'

それに変更する

ruby '2.3.0'

その後、

bundle install

あなたのGemfileに以下を追加してください

ruby '2.3.0'

私はMac OS Sierraを使っています。 /etc/pathsを更新して、 /etc/paths /Users/my.username/.rbenv/shims /etc/paths /Users/my.username/.rbenv/shims /etc/paths /Users/my.username/.rbenv/shims /etc/paths /Users/my.username/.rbenv/shimsをリストの先頭に追加する/Users/my.username/.rbenv/shimsました。





rubygems