ruby-on-rails - 意味 - set heroku_debug_rails_runner=1 to debug




Heroku CLIで何かを実行しようとすると、エラーが発生します。「HerokuのAPI MIMEタイプと一緒にバージョンを指定してください」 (4)

今朝の時点で、Heroku CLIの設定を変更せずに、実行しようとすると次のエラーが表示されましたheroku logs -t -app <app_name>

! Please specify a version along with Heroku's API MIME type. For example, Accept: application/vnd.heroku+json; version=3.

私はそれ以来、herokuとheroku-toolbeltの両方をbrew upgrade herokubrew upgrade heroku-toolbeltで更新しようとしましたが、これで問題は解決しませんでした。

heroku logsheroku appsheroku loginheroku auth:loginなど、heroku CLIで何かをやろうとすると必ずこのエラーが出heroku auth:login

私はMacOSを実行しています、そして、私がHerokuから戻ってきているのは投稿されたエラーだけです。

この議論はここにあります: どうすればherokuのMIMEタイプを指定できますか? UbuntuでHerokuをアップグレードすることに関するもので、私の問題は解決しません。


'heroku --version'コマンドを実行すると、ツールベルトが自動的にクライアントを更新します。 その後、ログインは大丈夫でした。



私はブリュー経由でherokuをインストールしたとき、私はmacOS Sierra 10.12.3で同じ問題を抱えていました。

それを回避するために、私はbrew uninstall heroku-toolbeltを実行し、それからhttps://devcenter.heroku.com/articles/heroku-cli#macos Macインストーラを介してインストールしました、そしてそれは今うまく働きます。


私は同じ問題を抱えていました - しかし新しいToolbeltをインストールすることは最初はうまくいきませんでした。 私がする必要があるもう一つのステップがありました。

から: https://devcenter.heroku.com/articles/heroku-cli : https://devcenter.heroku.com/articles/heroku-cli

それは新しいcliをインストールする上で各プラットフォームのための指示を持っています - そして、あなたは走る必要があると言います:正しいバージョンが走っていることを確かめるためにwhich heroku 。 私の場合、新しくインストールされたheroku-cliバイナリの代わりにgemバイナリを実行していたので、すべてをgem uninstall herokuためにgem uninstall herokuを実行する必要もありました。