ios - supported - xcode support device




iOS 11.2にデバイスをアップデートすると、Xcode 9.1でサポートが中断されます (4)

私は、iOS 11.2を実行しているデバイスでアプリケーションを実行しようとしましたが、次のエラーが発生しました:

デバイスでサポートされているファイルを見つけることができませんでした。

このiPhone 5(モデルA1457、A1518、A1528、A1530)はiOS 11.2(15C114)を実行していますが、このバージョンのXcodeではサポートされていない可能性があります。

私はiphone 5(バージョン11.1.2)を使用しており、xcode 9.1(ios 11.1)からプロジェクトをビルドしたいと考えています。


AppleがiOS 11.2を公開することなく、AppleがiOS 11.2をリリースしていない(Mac App Storeはこの記事の執筆時点で9.1を最新版として報告している)ようだ.iOS 11.2を実行するデバイスをターゲットするために必要なiOS 11.2 SDKが含まれている。 開発者アカウントをお持ちの場合は、Xcode 9.2ベータ版を使用してデバイス上でこれを実行することができます。このベータ版は、 開発者向けのダウンロードページからダウンロードできます

編集: Xcode 9.2は現在公開されており、 Mac App Storeからダウンロードできます




私のようなルーキーにとって、あなたがこのようなメッセージを受け取ったら:

「このiPhone 6はiOS 11.2.Xを実行していますが、このバージョンのXcodeではサポートされていない可能性があります。

つまり、Xcodeを更新する必要があります。

私の携帯電話が11.2.6を実行していて、Xcodeバージョン9.0を実行していたときにこの問題が発生しました

あなたはそれをApp Storeから更新することも、ここからダウンロードすることもできます: https://download.developer.apple.com/Developer_Tools/Xcode_9.2/Xcode_9.2.xip : https://download.developer.apple.com/Developer_Tools/Xcode_9.2/Xcode_9.2.xip





iphone