git 途中 フラッターインストール中のlibusbmuxdバージョンエラー




tortoisegit タグ付け (3)

libimobiledeviceへの最近の変更によりlibimobiledevice の制約が> = version 1.1.0にバンプしました 。 現在のusbmuxd homebrewパッケージはバージョンusbmuxdです。

その結果、homebrew - --HEADインストールは、もはや--HEADインストールなしでビルドされなくなりusbmuxd

usbmuxd自作式が更新されるまで、回避策はHEADにインストールすることです。

brew update
brew uninstall --ignore-dependencies libimobiledevice
brew uninstall --ignore-dependencies usbmuxd
brew install --HEAD usbmuxd
brew unlink usbmuxd
brew link usbmuxd
brew install --HEAD libimobiledevice

この問題に関する進捗状況は、 flutter/flutter#22595追跡できます。

フラッタのインストールと設定に問題があります

Mac OS Sierra 10.12.6で

Xcode 9.2

醸造医はすべてokを報告した

フラッター医師が報告

[!] iOS toolchain - iOSデバイス用に開発する(Xcode 9.2)

**libimobiledevice and ideviceinstaller are not installed. To install, run:
    brew install --HEAD libimobiledevice
    brew install ideviceinstaller**

プロンプト$:brew install - HEAD libimobiledevice

==> https://git.libimobiledevice.org/libimobiledevice.gitクローンする/ Users / rjoiner / Library / Caches / Homebrew / libimobiledeviceを更新する - git

==>既にブランチマスターをチェックアウトしています 'master'あなたのブランチは 'origin / master'で最新です。 HEADがb34e343ツールに追加されました:新しいデバイスをサポートするためにデバイスUDID引数の長さチェックを削除

==> ./autogen.sh /Users/rjoiner/Library/Logs/Homebrew/libimobiledevice/01.autogen.shからの最後の15行:動的リンカの特性のチェック... darwin16.7.0 dyldライブラリパスをプログラムにハードコードする方法のチェック... pkg-configの即時チェック... / usr / local / opt / pkg-config / bin / pkg-config

libusbmuxd> = 1.1.0 ... no configure:error:パッケージ要件(libusbmuxd> = 1.1.0)が満たされていないことを確認してください。

'libusbmuxd> = 1.1.0'が要求されましたが、libusbmuxdのバージョンは1.0.10です

libusbmuxdのバージョン1.1.0のインストール方法がわかりません

乾杯

ロブ


ちょっと奇妙ですが、 libusbmuxdusbmuxdです。 あなたはbrew install --HEAD usbmuxdを試みることができます - brew install --HEAD usbmuxd








flutter