maven - android studio gradle アップデート




Android Studio-intellij-core.jarが見つかりませんでした (8)

私はアンドロイドスタジオ3.1.4を使用しています。

エラー:intellij-core.jar(com.android.tools.external.com-intellij:intellij-core:26.0.1)が見つかりませんでした。 次の場所で検索しました: https://jcenter.bintray.com/com/android/tools/external/com-intellij/intellij-core/26.0.1/intellij-core-26.0.1.jar : https://jcenter.bintray.com/com/android/tools/external/com-intellij/intellij-core/26.0.1/intellij-core-26.0.1.jar


build.gradleファイルにgoogle()を追加すると、現時点で404を返すhttps://dl.google.com/dl/android/maven2/というURLが使用されます。

(出典: https://docs.gradle.org/current/javadoc/org/gradle/api/artifacts/dsl/RepositoryHandler.html#google-- : https://docs.gradle.org/current/javadoc/org/gradle/api/artifacts/dsl/RepositoryHandler.html#google--

現時点では、作業用URLはhttps://dl.google.com/dl/android/maven2/index.htmlです。google()をこの行に置き換えることでアクセスできます

maven {url ' https://maven.google.com '}

あなたのbuild.gradleファイル。


com.android.tools.build:gradle:3.2.1を使用

また、 '/gradle/wrapper/gradle-wrapper.properties'を更新する必要があります。

distributionUrl=https\://services.gradle.org/distributions/gradle-4.6-all.zip

https://github.com/flutter/flutter/pull/23397

つまり、上記リンクのMahi-Kに続​​いて、 $flutterRoot/packages/flutter_tools/gradle/flutter.gradleを編集する必要があり$flutterRoot/packages/flutter_tools/gradle/flutter.gradle

buildscript {
    repositories {
        google()
        jcenter()
        maven {
            url 'https://dl.google.com/dl/android/maven2'
        }
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.2.1'
    }
}

gradle/wrapper/gradle-wrapper.propertiesラッパーのプロパティーのgradle/wrapper/gradle-wrapper.propertiesでは、4.6以上に変更する必要があります

distributionUrl=https\://services.gradle.org/distributions/gradle-4.6-all.zip

私にとって、問題解決の変更は、Google Serverを取得するためにgradleファイルを作成します。
/platforms/android/build.gradle

allprojects {
    repositories {
        google()
        jcenter()
        maven {
            url "https://maven.google.com"
        }
    }

/platforms/android/app/build.gradle

allprojects {
    repositories {
        google()
        mavenCentral();
        jcenter()
    }

この問題はhttps://issues.apache.org/jira/browse/CB-14127https://issues.apache.org/jira/browse/CB-14127

問題のブレークダウン

基本的にjcenterにGoogle jarをアップロードする際に問題が発生し、ビルドが失敗する原因となっています。

修正

jcenterの前にgoogle mavenリポジトリを置くと、ビルドがうまくいきます。

7月18日に、cordova-android 7.1.1のリリースで問題が解決されているはずです。 変更ログはこちら

しかし、修正はすべてのケースで明らかに機能しませんでした。

それまでは、プラットフォームを削除して再追加するたびに注文を交換することを忘れないでください。


この問題を解決するには、

<preference name="android-targetSdkVersion" value="27" />

あなたのconfig.xmlに入れます。

それとももっと良い、android-cordovaをlatesバージョン(7.1.2)にアップグレードする:

cordova platform add [email protected]

android-cordova 7.1.2には、CB-14127の修正点が記載されています。「google maven repoをjcenterより先に移動する」 ( https://issues.apache.org/jira/browse/CB-14127


リポジトリの順序を変更することで問題を解決できました:

/platforms/android/CordovaLib/build.gradle

これから:

repositories {
    jcenter()
    maven {
        url "https://maven.google.com"
    }
}

これに:

repositories {
    maven {
        url "https://maven.google.com"
    }
    jcenter()
}

私は私の問題を解決する。 platform / android / CordovaLib / build.gradleファイルを変更してください。 私はmaven repoをjcenterの前に置いています。

repositories {
    maven {
        url "https://maven.google.com"
    }
    jcenter()

}

そして私はcordova-android 7.1.1を使用します。





android-gradle