android-studio - スペック - android studio 日本語




28.1.9以上のリビジョンを持つパッケージ "Android Emulator"は利用できません (3)

************編集****************

今日、安定版チャンネルでバージョン29.0.6が利用可能であることがわかりました。

「Check for Updates ...」をクリックするだけです。

私はある種の解決策を見つけました。

  1. 設定 - >アップデートと進みます。

  2. "Canary Cannel"を選択して "今すぐチェック"をクリック

  3. 「後で通知する」という更新を取り消します。

  1. [設定] - > [Android SDK] - > [SDKツール]に移動します。

  2. 「Android Emulator」チェックボックスを3回クリックします(チェックボックスの状態は最初と同じになります)。

  1. 設定 - >更新にもう一度行きます

  2. [安定したチャンネル]を選択して[今すぐ確認]をクリックします。

  3. 推奨アップデートをインストールします(Androidエミュレータから29.0.3)。

また、設定 - > Android SDK - > SDK PlatformsからAndroid Q Previewをダウンロードする必要があります。

わたしにはできる。 あなたを助けることを願っています:)

私はAVDマネージャを使用してAndroid Qを追加しようとしていますが、それは言っています: "パッケージ" Android Emulator "少なくとも28.1.9リビジョンは使用できません。 誰かが以前にこれを試したことがありますか? どうしたらいいの?


@ JulianCの おかげで私もエミュレータを設定しました。 公式サイトからスタンドアロンでダウンロードしようとしましたが、できませんでした。 それからCanary Channelに切り替えました。 Help > Checked for updates を押し、 Configure labelを押してチャンネルを変更した。

私はAndroid Studio 3.5をインストールしたくなかったので、 SDK Manager 、必要なエミュレータを更新しました。

その後、安定したチャンネルに戻りました。

更新

数日の作業の後、私はエミュレータの視覚的なバグに直面しました。 Android Qでもまだ実行されていません。 Cold Boot Now AVDマネージャから仮想デバイスを再起動しなければならない場合があり Cold Boot Now

AVD Managerで仮想デバイスを再作成することがあります。


https://developer.android.com/preview/release-notes 基づいて:

注:エミュレーター内からAndroid Q Beta 2エミュレーター・システム・イメージをダウンロードしようとすると、最新バージョンのエミュレーターをダウンロードするように指示されます。 Android Studioリリースの安定したチャンネルにいる場合は、カナリアチャンネルに切り替えてこの最新バージョンのエミュレータをダウンロードできるようにする必要があります。 カナリアチャンネルからすべてのAndroid Studioをダウンロードする必要はありません。SDKマネージャ内からカナリアチャンネルからエミュレータのみをダウンロードできます。

最新のエミュレータを入手するには、Android Studio Canaryビルドを使用する必要があります。 これは私のために働きました







android-studio