python バージョン履歴 - Pip:マイナーバージョンの指定



削除 戻す (2)

私のrequirements.txtファイルで、私のアプリケーションにDjangoバージョン1.3.xが必要であることを指定したいと思います。 つまり、1.3.0または1.3.1、または1.3.2など(これらが出たとき)ですが、出てくるときは1.4ではありません。

これの構文は何ですか?


Answers

イアンビッキングによると:

Django>=1.3,<1.4

しかし、それは明らかに安全である

Django>=1.3,<1.3.99

require.txtファイルをpython 3でvirtual envの中にインストールする:

私も同じ問題がありました。 私はrequirements.txtファイルを仮想環境の中にインストールしようとしていました。 私は解決策を見つけた。

最初に、私はこのように仮想envを作成しました:

virtualenv -p python3 myenv

以下を使用して環境をアクティブにします。

source myenv/bin/activate

これでrequirements.txtがインストールされました:

pip3 install -r requirements.txt

インストールは成功し、モジュールをインポートできました。





python pip distribute