python - インストール - filename.whlは、このプラットフォームではサポートされていません




scipy インストール ubuntu (16)

IISでPython34を使用してFlaskを展開しています。 次の手順は私のために働いた

  1. アップグレードpip
  2. numpyのホイールファイルをインストールする
  3. PIPインストールパンダ

ローカルドライブに保存した scipy-0.15.1-cp33-none-win_amd64.whl をインストールしたいです。 私は使っている:

pip 6.0.8 from C:\Python27\Lib\site-packages
python 2.7.9 (default, Dec 10 2014, 12:28:03) [MSC v.1500 64 bit (AMD64)]

私が実行するとき:

pip install scipy-0.15.1-cp33-none-win_amd64.whl

次のエラーが表示されます。

scipy-0.15.1-cp33-none-win_amd64.whl is not supported wheel on this platform

私は問題が何であるか知りたいですか?


Python 3.6で新しく作成された仮想環境で、 here で指定されて here とおりにTensorFlowのインストールを検証しようとして here ました。 実行中:

pip3 install --ignore-installed --upgrade "/Users/Salman/Downloads/tensorflow-1.12.0-cp37-cp37m-macosx_10_13_x86_64.whl"

エラーや警告が表示されます:

tensorflow-1.12.0-cp37-cp37m-macosx_10_13_x86_64.whl is not a supported wheel on this platform.

以前は pip から pip3に アップグレードしていたので、次のように pip pip3に 置き換えました。

pip3 install --ignore-installed --upgrade "/Users/Salman/Downloads/tensorflow-1.12.0-cp37-cp37m-macosx_10_13_x86_64.whl"

そしてそれは魅力のように働いた!


Pythonを初めて使用する場合は、手順を1つずつ読むか、直接5番目の手順に進んでください。 以下の方法に従って、Windows 64ビット、Python 64ビットにscipy 0.18.1をインストールします。 1. Python 2. Windows 3. .whlバージョンのnumpyおよびscipyファイル のバージョンに注意して ください4. 最初にnumpyをインストールしてから、scipyをインストールし ます

pip install FileName.whl
  1. ForNumpy: here ://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy ForScipy: here //www.lfd.uci.edu/~gohlke/pythonlibs/#scipy

ファイル名に注意してください(つまり、cp noをチェックします)。 例:scipy-0.18.1-cp35-cp35m-win_amd64.whlどのcpがpipでサポートされているかを確認するには、以下のポイント2に進みます。

.whlファイルを使用している場合。 次のエラーが発生する可能性があります。

  1. pipバージョン7.1.0を使用していますが、バージョン8.1.2が使用可能です。

「python -m pip install --upgrade pip」コマンドによるアップグレードを検討する必要があります

  1. scipy-0.15.1-cp33-none-win_amd64.whl.whlはこのプラットフォームではサポートされていません

上記のエラーの場合:Pythonを起動します(私の場合は3.5)、次を入力します: import pip print(pip.pep425tags.get_supported())

出力:

[( 'cp35'、 'cp35m'、 'win_amd64')、( 'cp35'、 'none'、 'win_amd64')、( 'py3'、 'none'、 'win_amd64')、( 'cp35'、 'none '、' any ')、(' cp3 '、' none '、' any ')、(' py35 '、' none '、' any ')、(' py3 '、' none '、' any ')、( 「py34」、「none」、「any」)、(「py33」、「none」、「any」)、(「py32」、「none」、「any」)、(「py31」、「none」、 'any')、( 'py30'、 'none'、 'any')]

出力では、cp35があることがわかります。したがって、numpyおよびscipyのcp35をダウンロードしてください。 それ以上の編集は大歓迎です!!!!


scikit-imageをインストールしようとしましたが、Pythonのインストール済みバージョンが2.7 32ビットであったにもかかわらず、.whlファイルをインストールしようとすると、次のエラーが発生しました。 scikit_image-0.12.3-cp27-cp27m-win32.whl is not a supported wheel on this platform.

ただし、エラーメッセージの前にこのメッセージも表示されました。

You are using pip version 7.1.0, however version 8.1.2 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.

次に、コマンド python -m pip install --upgrade pip から、 pip install scikit_image-0.12.3-cp27-cp27m-win32.whl 機能しました。 これが誰かを助けることを願っています!


これは、最新のホイールファイルで古い pip を使用することによっても発生します。

numpy-1.10.4+mkl-cp27-cp27m-win_amd64.whlhere から)をインストールしていたので、私は非常に混乱しました。これは間違いなく私のPythonインストール(Windows 64ビットPython 2.7.11)の正しいバージョンです。 「このプラットフォームでサポートされていないホイール」エラーが発生しました。

python -m pip install --upgrade pip pipをアップグレードすると解決しました。


すべてのプラットフォーム要件 は* .whl ファイルの 名前から取られている ことに注意してください!

そのため、*。whlパッケージの 名前変更に は十分注意してください。 私は時折、新しくコンパイルされたテンソルフローパッケージの名前を

tensorflow-1.11.0-cp36-cp36m-linux_x86_64.whl

tensorflow-1.11.0-cp36-cp36m-linux_x86_64_gpu.whl

GPUのサポートについて思い出し、苦労した

tensorflow-1.11.0-cp36-cp36m-linux_x86_64_gpu.whlは、このプラットフォームでサポートされているホイールではありません。

約30分間のエラー。


まず、 cp33 は、システムで Python 3.3を 実行しているときに使用されることを意味します。 システムに Python 2.7がある 場合は、 cp27 バージョンをインストールして ください

scipy-0.18.1-cp27-cp27m-win_amd64.whlをインストールする には、Python 2.7が実行され、64ビットシステムが必要です。

「scipy-0.18.1-cp27-cp27m-win_amd64.whlはこのプラットフォームでサポートされているホイールではありません」というエラーが引き続き表示される場合は、win32バージョンに進みます。 これにより、最初のものではなく scipy-0.18.1-cp27-cp27m-win32.whlを インストールすることになります。 これは、64ビットシステムで32ビットpythonを実行している可能性があるためです。 最後のステップでscipyが正常にインストールされました。


インストールのためにcondaを試してください、その場でバージョンを解決するようです:
conda install scikit-learn


パッケージをインストールするpythonのバージョンを確認することをお勧めします。 ホイールがpython3用に構築されており、pythonバージョンがpython2.xの場合、このエラーが発生する可能性があります。 pipを使用してインストールする際は、この規則に従ってください

python2 -m pip install XXXXXX.whl #if .whl is for python2
python3 -m pip install XXXXXX.whl #if .whl is for python3

ファイル名を scipy-0.15.1-cp33-none-any.whl 変更して、次のコマンドを実行します。

pip install scipy-0.15.1-cp33-none-any.whl

動作するはずです:-)


同じ問題があった

https://pypi.org/project/pip/#files から最新のpipをダウンロードしました

そして.... pip install <<ダウンロードしたファイルの場所>>

その後、pygameとkivyのインストールはうまくいきました...ありがとう... !!


同様の問題がありました。Windows7 64ビットにpython27用の64ビットバージョンをインストールしました。 すべてが最新でしたが、私はメッセージを受け取りました

scipy-0.18.1-cp27-cp27m-win_amd64.whl is not supported wheel on this platform

私が32ビットのWHLをダウンロードし、それが機能したよりも。

pip install scipy-0.18.1-cp27-cp27m-win32.whl

問題はおそらくAMDプロセッサを持っているのではなく、Intelプロセッサを持っていることであり、scipy 64ビットバージョンでは最終的にamd64であると思われます。


私にとっては、コンピューターバージョンではなく、Pythonバージョンの正しいビットを選択したときに機能しました。

私のものは32ビットで、私のコンピューターは64ビットです。 それが問題であり、32ビット版で修正されました。

正確には、ここに私がダウンロードして私のために働いたものがあります:

mysqlclient-1.3.13-cp37-cp37m-win32.whl

繰り返しになりますが、システムのバージョンではなく、Pythonバージョンのビットを選択してください。


私の場合[Win64、Python 2.7、cygwin]では、 gcc が見つからないという問題がありました。

apt-cyg install gcc-core 使用すると、 pip2 wheel ... を使用して、ホイールを自動的にインストールできます。


cp33 は、代わりに scipy‑0.15.1‑cp27‑none‑win_amd64.whl が必要な CPython 3.3 を意味します。


Tensorflowの 構成中に、 python3.6 を指定し ました 。 しかし、私のシステムのデフォルトのpythonは python2.7 です。 したがって、私の場合のpipは2.7のpipを意味します。 私のために

pip3 install /tmp/tensorflow_pkg/NAME.whl

トリックをしました。





pip