ios - update - 코코아팟




이전 버전의 Cocoapods를 다운 그레이드하거나 설치하는 방법 (4)

방금 실행할 수있는 현재 버전을 제거하려면 다음을 수행하십시오.

sudo gem uninstall cocoapods

다음 명령을 통해 특정 버전의 코코아 포드를 설치할 수 있습니다 :

sudo gem install cocoapods -v 0.25.0

다음 명령을 사용하여 이전에 설치된 버전을 사용할 수 있습니다.

pod _0.25.0_ setup

어떻게하면 Cocoapods를 이전 버전으로 다운 그레이드 할 수 있습니까? 아니면 이전 버전의 Cocoapods를 설치할 수 있습니까?


사실, 다운 그레이드 할 필요가 없습니다 - 일부 프로젝트에서 이전 버전을 사용해야하는 경우 pod 명령 이후에 사용해야하는 버전을 지정하십시오.

pod _0.37.2_ setup

포드 사양은 그대로 유지되며 ~ / .cocoapods /에 있습니다. 이 디렉토리는 완전히 새로 설치하려는 경우 제거해야 할 수도 있습니다.

pod spec remove SPEC_NAMEpod setup 사용하여 제거 할 수 있습니다.

그것은 pod spec remove master 데 도움이 될 수 pod spec remove master 다음 pod setup pod spec remove master


PROMPT> gem uninstall cocoapods

Select gem to uninstall:
 1. cocoapods-0.32.1
 2. cocoapods-0.33.1
 3. cocoapods-0.36.0.beta.2
 4. cocoapods-0.38.2
 5. cocoapods-0.39.0
 6. cocoapods-1.0.0
 7. All versions
> 6
Successfully uninstalled cocoapods-1.0.0
PROMPT> gem install cocoapods -v 0.39.0
Successfully installed cocoapods-0.39.0
Parsing documentation for cocoapods-0.39.0
Done installing documentation for cocoapods after 1 seconds
1 gem installed
PROMPT> pod --version
0.39.0
PROMPT>






cocoapods