OS X 업데이트 후 MobileDevice.pkg를 신뢰할 수 없으며 Xcode를 열 수 없습니다




macos macos-catalina (6)

macOS v10.15 (Catalina)의 자동 업데이트 후 Xcode를 열 수 없습니다. Xcode에서 추가 구성 요소를 설치하라는 메시지를 표시하지만 MobileDevice.pkg (Applications / Xcode.app / Contents / Resources / Packages)로 인해 설치가 실패 함

MobileDevice.pkg를 찾는 방법에 대한 여러 답변을 찾았으며 직접 설치하려고 시도해야하지만이를 시도하면 설치도 실패합니다. App Store 에서 Xcode 업데이트를 시도했지만 업데이트가 거의 완료되지 않았습니다.

누구든지 같은 행동을 경험 한 적이 있습니까? Mac을 기본값으로 재설정하고 macOS v10.13 (High Sierra) 또는 Catalina를 처음부터 설치해야합니까 아니면 Xcode의 문제이며 다시 설치하면 작업이 수행됩니까?

오늘 게시 된 토론을 발견했으며 아마도 같은 문제에 관한 것일 수 있으며 많은 사람들 이이 문제를 다루는 것처럼 보입니다.

일지:

*2019-10-25 01:03:34+02 Vendula-MacBook-Pro Xcode[1567]: Package: PKLeopardPackage 
<id=com.apple.pkg.MobileDevice, version=4.0.0.0.1.1567124787, url=file:///Applications/Xcode.app/Contents/Resources/Packages/MobileDevice.pkg> 
Failed to verify with error: Error Domain=PKInstallErrorDomain Code=102 
"The package “MobileDevice.pkg” is untrusted." 
UserInfo={
  NSLocalizedDescription=The package MobileDevice.pkg is untrusted., 
  NSURL=MobileDevice.pkg -- file:///Applications/Xcode.app/Contents/Resources/Packages/, 
  PKInstallPackageIdentifier=com.apple.pkg.MobileDevice, 
  NSUnderlyingError=0x7fabf6626d00 
  {
    Error Domain=NSOSStatusErrorDomain 
    Code=-2147409654 "CSSMERR_TP_CERT_EXPIRED" 
    UserInfo={
      SecTrustResult=5, 
      PKTrustLevel=PKTrustLevelExpiredCertificate,   
      NSLocalizedFailureReason=CSSMERR_TP_CERT_EXPIRED
    }
  }
}*

2019 년 10 월 1 일로 Mac 날짜를 편집하고 설정하십시오.


Mac의 날짜를 2019 년 10 월 1 일로 설정하면이 문제를 해결할 수 있습니다. 그러나 이것은 해킹입니다! 실제 솔루션 (애플이 제안한)은 다음과 같습니다.

Xcode를 업그레이드하기 만하면됩니다.

그러나 애플 개발자 사이트에 알려진 문제가 있습니다

macOS Catalina로 업데이트 한 후 Mac App Store에서 Xcode를 업데이트하지 못할 수 있습니다. (56061273)

애플은 이것을 제안한다 :

새로운 다운로드를 시작하려면 기존 Xcode.app를 삭제하거나 파일 확장자를 임시로 변경하여 더 이상 App Store에 표시되지 않도록 할 수 있습니다.

또는

항상 작동하는 솔루션 사용 :

  1. 여기로 가서 로그인하십시오 :

http://developer.apple.com/account

  1. 그런 다음 여기에서 dmg를 다운로드하십시오.

https://developer.apple.com/services-account/download?path=/Developer_Tools/Xcode_11.1/Xcode_11.1.xip

이 답변에 대한 자세한 내용은 여기를 참조 하십시오 .


Xcode 11.1이 설치되어 있어야합니다.

macOS Catalina를 10.15.1로 업데이트 할 때까지 Xcode 11.1로 업데이트 할 수 없었습니다. macOS를 업데이트 한 후 Xcode 11.1을 설치하여 추가 구성 요소 패키지를 설치할 수있었습니다.


Xcode 11.1이 설치되어 있지 않았지만 아래 해결 방법 후에 11.0을 열고 실행할 수 있지만 업데이트가 항상 실패했기 때문에 11.1로 업데이트 할 수 없었습니다. 방금 App-Store에서 전체 앱을 다시 설치했습니다. 아래 방법 대신이 작업을 수행 할 수도 있습니다.

인증서가 여전히 유효해야하는 2019 년 10 월 1 일로 시스템 시간을 설정하려고했습니다. 그 후 Xcode를 열려고 시도한 구성 요소 설치를 따르고 이제 Xcode로 다시 작업 할 수 있습니다.


추가 구성 요소를 설치하려면 Xcode 대신 Xcode-beta 를 실행하십시오. 그 후 Xcode 릴리스를 사용할 수 있습니다.








macos-catalina