Pacotes que não são carregados após a instalação do visual studio 2015 RTM




visual-studio visual-studio-2015 (8)

O problema

Eu tinha o Visual Studio 2015 RC instalado e instalado o Visual Studio 2015 RTM sobre ele. Eu não consegui encontrar nada na internet que dizia que você não poderia fazer isso. Não sei se isso é relevante para o problema.

Infelizmente, quando iniciei o VS 2015 RTM pela primeira vez depois de reiniciá-lo, apareci caixas de mensagem com:

"O pacote 'Microsoft.VisualStudio.Editor.Implementation.EditorPackage' não foi carregado corretamente"

Além disso:

  • XamarinShellPackage
  • TestWindowPackage
  • NuGetPackage
  • ErrorListPackage

Como posso resolver esse erro?

Logs

Ele disse para procurar no ActivityLog.xml . Não consegui encontrar o Microsoft.VisualStudio.Editor.Implementation.EditorPackage.

Mas para o XamarinShellPackage ele disse:

<entry>
    <record>339</record>
    <time>2015/07/21 13:01:54.011</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>SetSite failed for package [XamarinShellPackage]</description>
    <guid>{2D510815-1C4E-4210-BD82-3D9D2C56C140}</guid>
    <hr>80070057 - E_INVALIDARG</hr>
    <errorinfo>'providers' cannot contain a null (Nothing in Visual Basic) element.
Parameter name: providers</errorinfo>
  </entry>
  <entry>
    <record>340</record>
    <time>2015/07/21 13:01:54.013</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>End package load [XamarinShellPackage]</description>
    <guid>{2D510815-1C4E-4210-BD82-3D9D2C56C140}</guid>
    <hr>80070057 - E_INVALIDARG</hr>
    <errorinfo>'providers' cannot contain a null (Nothing in Visual Basic) element.
Parameter name: providers</errorinfo>
  </entry>

Para TestWindowPackage :

<entry>
   <record>394</record>
   <time>2015/07/21 13:02:02.751</time>
   <type>Error</type>
   <source>TestWindowPackage</source>
   <description>TestWindowPackage.Initialize failed with exception:
&#x000D;&#x000A;&#x000D;&#x000A;System.NullReferenceException:
Object reference not set to an instance of an object.&#x000D;&#x000A;
at Microsoft.VisualStudio.TestWindow.VsHost.TestWindowPackage.Initialize()
&#x000D;&#x000A;&#x000D;&#x000A;PackageContainer loaded: False &#x000D;&#x000A;</description>
</entry>
<entry>
   <record>395</record>
   <time>2015/07/21 13:02:02.752</time>
   <type>Error</type>
   <source>VisualStudio</source>
   <description>SetSite failed for package [TestWindowPackage]</description>
   <guid>{BFC24BF4-B994-4757-BCDC-1D5D2768BF29}</guid>
   <hr>80004003 - E_POINTER</hr>
   <errorinfo>Object reference not set to an instance of an object.</errorinfo>
</entry>

Para NuGetPackage :

 <entry>
    <record>405</record>
    <time>2015/07/21 13:02:04.096</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>SetSite failed for package [NuGetPackage]</description>
    <guid>{5FCC8577-4FEB-4D04-AD72-D6C629B083CC}</guid>
    <hr>80004003 - E_POINTER</hr>
    <errorinfo>Object reference not set to an instance of an object.</errorinfo>
  </entry>
  <entry>
    <record>406</record>
    <time>2015/07/21 13:02:04.096</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>End package load [NuGetPackage]</description>
    <guid>{5FCC8577-4FEB-4D04-AD72-D6C629B083CC}</guid>
    <hr>80004003 - E_POINTER</hr>
    <errorinfo>Object reference not set to an instance of an object.</errorinfo>
  </entry>

Para ErrorListPackage ele disse:

<entry>
    <record>409</record>
    <time>2015/07/21 13:02:04.624</time>
    <type>Information</type>
    <source>VisualStudio</source>
    <description>Begin package load [ErrorListPackage]</description>
    <guid>{4A9B7E50-AA16-11D0-A8C5-00A0C921A4D2}</guid>
  </entry>
  <entry>
    <record>410</record>
    <time>2015/07/21 13:02:04.629</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>SetSite failed for package [ErrorListPackage]</description>
    <guid>{4A9B7E50-AA16-11D0-A8C5-00A0C921A4D2}</guid>
    <hr>80004003 - E_POINTER</hr>
    <errorinfo>Object reference not set to an instance of an object.</errorinfo>
  </entry>

O que eu tentei até agora

Então ... Alguma sugestão por aí?

Atualizações para a pergunta

Primeira atualização

Eu apenas tentei carregar um projeto e ... Algo está muito errado. Não é possível carregar um monte de pacotes como: "CSharpPackage, IntegrationPackage, MigrationPackage, FileIndicatorPackage, etc ..." e o Solution Explorer está completamente em branco! O que está acontecendo?

Segunda atualização

É assim que meus Programas e Recursos se parecem:

Terceira atualização

Eu desinstalei e removi o quanto me atrevi.

  • Removido tudo em AppData \ Roaming \ Microsoft \ VisualStudio \ 14.0
  • Removido tudo em AppData \ Local \ VisualStudio \ 14.0
  • Visual Studio 2015 desinstalado por meio de programas e recursos (imagem acima)
  • Removida a pasta do Instalador Secundário do Visual Studio na pasta Arquivos de Programas completamente
  • Removido tudo o que tem a ver com o Visual Studio 14.0 a partir de arquivos de programas

Eu não quero estragar minha instalação do Visual Studio 2013. VS2015 ainda não pode carregar os pacotes acima! Então, se alguém tiver mais informações sobre quais programas exatamente podem ser desinstalados da captura de tela acima, ficarei muito feliz.

Quarta atualização

Etapas a serem tomadas (atualizadas a partir da atualização 3)

  • Removido tudo em AppData \ Roaming \ Microsoft \ VisualStudio \ 14.0
  • Removido tudo em AppData \ Local \ VisualStudio \ 14.0
  • Remover tudo sobre o Visual Studio 14.0 do ProgramData
  • Visual Studio 2015 desinstalado por meio de programas e recursos (imagem acima)
  • Fiz tudo o que este artigo diz: https://support.microsoft.com/nl-nl/kb/3016536
  • Removida a pasta do Instalador Secundário do Visual Studio na pasta Arquivos de Programas completamente
  • Removido tudo o que tem a ver com o Visual Studio 14.0 de Arquivos de Programas, basicamente. Tudo o que resta da desinstalação em Programas e Recursos.
  • Desinstale o Microsoft Visual C ++ redistribuível (x86) - 14.0.xxx também
  • Desinstalado meu material Xamarin também
  • Espero não ter esquecido nada, mas bottomline é se livrar totalmente de qualquer coisa relacionada ao visual studio 2015.
  • Reinstale o visual studio 2015 RTM e ele deve funcionar agora. Eu tenho que instalar algum material de terceiros novamente, mas pelo menos funciona!

A única coisa que funcionou para mim foi Reparar as Ferramentas de Dados do SQL Server (Ir para Desinstalar Programas e selecionar Alterar / Reparar)


Ao iniciar o Microsoft Visual Studio Enterprise 15 Preview (versão 15.0.25123), ocorreu o mesmo erro:

<entry>
    <record>27</record>
    <time>2016/05/02 12:26:57.451</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>SetSite failed for package [Image Service Package]Source:
 ..
    <guid>{1491E936-6FFE-474E-8371-30E5920D8FDD}</guid>
    <hr>80131522</hr>
    <errorinfo></errorinfo>
</entry>

Eu tento alterar a chave do registro , mas não funcionou.

Eu realmente nunca trabalhei, desinstalei a versão anterior, mas tente e funcionou!

Uninstall Microsoft Visual Studio Ultimate 2015 Preview, (Version 14.0.23310)

TRABALHOU (para mim :))

Eu corro todas as dicas acima também. Eu não sei se isso é necessário ou não. Uma saudação cordial.


Eu tenho visual studio 2012, 2013 e 2015 todos instalados na minha máquina. Depois de instalar o Visual Studio 2013 Update 5, comecei a receber o erro "pacote não foi carregado corretamente" no VS 2013.

Tudo o que fiz para funcionar foi seguir este passo:

  1. Feche todas as instâncias do Visual Studio
  2. Exclua tudo nesta pasta C:\Users\%username%\AppData\Local\Microsoft\VisualStudio\12.0\ComponentModelCache
  3. Reinicie o Visual Studio

Embora eu não tenha tentado isso para 2015, acredito que isso também deveria resolver o problema. Para fazer isso para o visual studio 2015, 12.0 deve ser alterado para 14.0

ATUALIZAR

Em vez de excluir tudo na pasta (como sugerido pela etapa 2 acima), é muito mais seguro renomear a pasta e permitir que o Visual Studio crie uma nova. Às vezes, você pode ter que copiar algumas coisas da pasta antiga.

Espero que isso ajude ainda mais a todos vocês.


Eu tive o mesmo problema com o VS 2015 Community RTC e foi capaz de corrigir isso excluindo tudo em:

  1. C:\Users\<your users name>\AppData\Local\Microsoft\VisualStudio\14.0 e
  2. C:\Users\<your users name>\AppData\Roaming\Microsoft\VisualStudio\14.0

Então, eu recomendaria tentar isso como você pode ser capaz de evitar a desinstalação / reinstalação VS


Mais uma solução alternativa para o Visual Studio 2015 Update 1

  1. Abra c:\Users\{User_Name}\AppData\Local\Microsoft\VisualStudio\14.0\devenv.exe.config
  2. Altere o redirecionamento de ligação para System.Collections.Immutable , newVersion deve ser 1.1.37.0 (não 1.1.36.0 ).

O redirecionamento deve ser assim:

    <dependentAssembly>
        <assemblyIdentity name="System.Collections.Immutable" publicKeyToken="b03f5f7f11d50a3a" culture="neutral"/>
        <bindingRedirect oldVersion="1.0.27.0-1.1.65535.65535" newVersion="1.1.37.0"/>
    </dependentAssembly>

Erro de ActivityLog.xml :

SetSite falhou para o pacote [CSharpPackage] [Não foi possível carregar o arquivo ou assembly 'System.Collections.Immutable, Version = 1.1.36.0, Culture = neutral, PublicKeyToken = b03f5f7f11d50a3a' ou uma de suas dependências. A definição de manifesto do assembly localizado não corresponde à referência de assembly. (Exceção de HRESULT: 0x80131040)]: {em Microsoft.VisualStudio.LanguageServices.Implementation.LanguageService.AbstractPackage`2.Initialize () em Microsoft.VisualStudio.LanguageServices.CSharp.LanguageService.CSharpPackage.Initialize () em Microsoft.VisualStudio.Shell .Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite (IServiceProvider sp)}

Você pode ler mais sobre como solucionar esses problemas no meu post Como restaurar o Visual Studio 2015 após a atualização 1


Meu problema aconteceu depois de instalar o Visual Studio 2015 Update 1

Eu tentei todas as soluções sugeridas sem sorte, A solução que funcionou para mim foi uma de Eric Knox (equipe da Microsoft)

É isso

  1. Faça o download da configuração correta do VSUpdate 1 para uma pasta em sua máquina neste link: https://download.microsoft.com/download/2/7/6/276D15B2-6851-42AA-8D1F-639CD3FC84BE/devenv-exe-config-update1.xml
  2. Abra um prompt de comando do administrador e execute estas etapas (supondo que você instalou no local padrão):

    cd "%ProgramFiles(x86)%\Microsoft Visual Studio 14.0\Common7\IDE"
    ren devenv.exe.config devenv.exe.config.backup
    copy <local path to file downloaded in step #1> .\devenv.exe.config
    devenv /UpdateConfiguration
    

Você pode conferir o artigo completo dele aqui


Semelhante à solução do @Tom Clelford, mas além de excluir tudo em:

C: \ Users {nome de usuário} \ AppData \ Local \ Microsoft \ VisualStudio \ 14.0

Eu tive que também apagar tudo em

C: \ Usuários {nome de usuário} \ AppData \ Local \ Microsoft \ VisualStudio \ vshub

Não precisei tocar em nada na pasta Roaming, mas isso pode variar de usuário para usuário.


Também tinha um no Visual Studio 2015 RC.

Problema usando "File-> New-> Project .." lançando exceção

Seguiu a resposta de Shittu Olugbenga, 10 de agosto, excluindo o conteúdo da pasta: "C: \ Usuários \\ AppData \ Local \ Microsoft \ VisualStudio \ 14.0 \ ComponentModelCache".

Reiniciei o Visual Studio e funcionou. :) Tnx.





visual-studio-2015