javascript - sweetalert - npm org js




npm WARN descontinuado [email protected]: graceful-fs versão 3 (4)

Estou executando o npm install, mas está me dando um erro. Eu também tentei executar o comando abaixo antes da atualização. $ npm install npm e também atualizei o graceful-fs.

$ npm install -g graceful-fs
graceful-[email protected].1.3 C:\Users\RDY672\AppData\Roaming\npm\node_modules\graceful-fs

ERRO é o seguinte:

$ npm install -g [email protected].3.12
npm WARN deprecated graceful-[email protected].0.8: graceful-fs version 3 and before will fail on newer node releases. Please update to graceful-[email protected]^4.0.0 as soon as possible.
npm WARN deprecated graceful-[email protected].0.3: graceful-fs version 3 and before will fail on newer node releases. Please update to graceful-[email protected]^4.0.0 as soon as possible.
npm WARN deprecated [email protected].1.2: this package has been reintegrated into npm and is now out of date with respect to npm
npm ERR! cb() never called!
npm ERR! not ok code 0

Concordo com todos os comentários a respeito de que isso não afeta em nada. Mas no caso de você querer atualizar.

Primeiro, verifique quais versões você já possui do gracioso

$ npm ls graceful-fs

e se você não tiver a versão mais recente, instale-a

$ sudo npm install -g graceful-fs graceful-[email protected]-version

Estou usando a plataforma Windows e Homestead. Os seguintes comandos no console funcionam para mim:

npm install --no-bin-links
gulp
npm rebuild node-sass
gulp

npm install -g graceful-fs [email protected] funciona para mim.

Isso instala a versão mais recente do graceful-fs !!


TL; DR: Apenas arquive os bugs, se necessário, e ignore os avisos de descontinuação por enquanto. A menos que esteja lançando erros, o problema não é seu.

Muito provavelmente, depende indiretamente de uma versão desatualizada do graceful-fs que depende dos módulos internos do Node (mesmo que não deva). Esse módulo, por necessidade , depende muito dos detalhes de implementação do Node, mas o 4.x foi escrito para ser menos quebradiço nesse aspecto. Poucas coisas foram alteradas na API entre 3.xe 4.x.

Pelo que vale, uma contagem de algumas semanas atrás teve esse módulo como o décimo mais baixado no NPM. Não vejo isso mudando muito. E devido ao grande compartilhamento de uso desse módulo (o npm em si depende indiretamente de uma versão desatualizada), o Node já instalou uma correção temporária na qual eles estão tentando tirar as pessoas dos módulos internos .

Portanto, não se preocupe, a menos que você receba erros provenientes dele. Geralmente ignoro esses avisos de descontinuação, pois eles já são muito conhecidos.







bower